aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libdbi
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libdbi')
-rw-r--r--recipes/libdbi/libdbi-drivers_0.7.1.bb40
-rw-r--r--recipes/libdbi/libdbi_0.7.2.bb22
2 files changed, 62 insertions, 0 deletions
diff --git a/recipes/libdbi/libdbi-drivers_0.7.1.bb b/recipes/libdbi/libdbi-drivers_0.7.1.bb
new file mode 100644
index 0000000000..eea45ca4bb
--- /dev/null
+++ b/recipes/libdbi/libdbi-drivers_0.7.1.bb
@@ -0,0 +1,40 @@
+# libdbi-drivers OE build file
+# Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Database Drivers for libdbi"
+HOMEPAGE = "http://libdbi-drivers.sourceforge.net/"
+LICENSE = "GPLv2"
+SECTION = "libs"
+
+PROVIDES = "libdbd-sqlite"
+DEPENDS = "libdbi sqlite"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libdbi-drivers/libdbi-drivers-${PV}.tar.gz"
+
+inherit autotools
+
+PACKAGES = "${PN}-dbg libdbd-sqlite ${PN}"
+
+EXTRA_OECONF = "--with-dbi-incdir=${STAGING_INCDIR} \
+ --with-sqlite \
+ --with-sqlite-libdir=${STAGING_LIBDIR} \
+ --with-sqlite-incdir=${STAGING_INCDIR}"
+
+FILES_libdbd-sqlite = "/usr/lib/dbd/libsqlite.so \
+ /usr/lib/dbd/libsqlite.la \
+ /usr/lib/dbd/libsqlite.a"
+
+DESCRIPTION_libdbd-sqlite = "SQLite database driver for libdbi"
+
+do_configure_old () {
+ ./configure \
+ --build=${BUILD_SYS} \
+ --host=${HOST_SYS} \
+ --target=${TARGET_SYS} \
+ --prefix=${prefix} \
+ --with-sqlite \
+ --with-sqlite-libdir=${STAGING_LIBDIR} \
+ --with-sqlite-incdir=${STAGING_INCDIR}
+}
+
diff --git a/recipes/libdbi/libdbi_0.7.2.bb b/recipes/libdbi/libdbi_0.7.2.bb
new file mode 100644
index 0000000000..8737890368
--- /dev/null
+++ b/recipes/libdbi/libdbi_0.7.2.bb
@@ -0,0 +1,22 @@
+# libdbi OE build file
+# Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Database Independent Abstraction Layer for C"
+HOMEPAGE = "http://libdbi.sourceforge.net/"
+LICENSE = "LGPL"
+SECTION = "libs"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libdbi/libdbi-${PV}.tar.gz"
+
+inherit autotools
+
+do_stage () {
+ autotools_stage_includes
+ cd ./src/.libs/
+ oe_libinstall -so libdbi ${STAGING_LIBDIR}
+}
+
+do_configure () {
+ autotools_do_configure
+} \ No newline at end of file