aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libetpan/libetpan_0.48.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libetpan/libetpan_0.48.bb')
-rw-r--r--recipes/libetpan/libetpan_0.48.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/libetpan/libetpan_0.48.bb b/recipes/libetpan/libetpan_0.48.bb
new file mode 100644
index 0000000000..dfef3b19c6
--- /dev/null
+++ b/recipes/libetpan/libetpan_0.48.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "libetpan is a library for communicating with mail and news servers. \
+It supports the protocols SMTP, POP3, IMAP and NNTP."
+HOMEPAGE = "http://www.etpan.org"
+SECTION = "libs"
+DEPENDS = "gnutls"
+LICENSE = "BSD"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libetpan/libetpan-${PV}.tar.gz \
+ file://honor-oe-lflags.patch;patch=1"
+
+inherit autotools pkgconfig gettext binconfig
+
+EXTRA_OECONF = "--without-openssl --with-gnutls --disable-db"
+
+PARALLEL_MAKE = ""
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev = "${bindir} ${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libdir}/pkgconfig"