aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libexif/libexif_0.5.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libexif/libexif_0.5.12.bb')
-rw-r--r--recipes/libexif/libexif_0.5.12.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/libexif/libexif_0.5.12.bb b/recipes/libexif/libexif_0.5.12.bb
new file mode 100644
index 0000000000..94f3bee856
--- /dev/null
+++ b/recipes/libexif/libexif_0.5.12.bb
@@ -0,0 +1,16 @@
+SECTION = "libs"
+DESCRIPTION = "Library to read the extended image information (EXIF) from JPEG pictures"
+LICENSE = "LGPL"
+SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_libinstall -a -so -C libexif libexif ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/libexif
+ for X in exif-byte-order.h exif-data.h exif-format.h exif-loader.h exif-tag.h exif-content.h exif-entry.h exif-ifd.h exif-result.h exif-utils.h
+ do
+ install -m 0644 ${S}/libexif/$X ${STAGING_INCDIR}/libexif/$X
+ done
+}