aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libfakekey/libfakekey_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libfakekey/libfakekey_svn.bb')
-rw-r--r--recipes/libfakekey/libfakekey_svn.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/libfakekey/libfakekey_svn.bb b/recipes/libfakekey/libfakekey_svn.bb
new file mode 100644
index 0000000000..946080cf33
--- /dev/null
+++ b/recipes/libfakekey/libfakekey_svn.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Matchbox keyboard"
+LICENSE = "GPL"
+DEPENDS = "libxtst"
+SECTION = "x11/wm"
+PV = "0.2+svnr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
+ file://configure-fix.patch;patch=1"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig gettext
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/fakekey
+ install -m 0644 ${S}/fakekey/fakekey.h ${STAGING_INCDIR}/fakekey
+ oe_libinstall -so -C src libfakekey ${STAGING_LIBDIR}
+}