aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libgc/libgc_6.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libgc/libgc_6.5.bb')
-rw-r--r--recipes/libgc/libgc_6.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/libgc/libgc_6.5.bb b/recipes/libgc/libgc_6.5.bb
new file mode 100644
index 0000000000..e99a38f396
--- /dev/null
+++ b/recipes/libgc/libgc_6.5.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Garbage collector for C and C++"
+LICENSE = "As is"
+HOMEPAGE = "http://www.hpl.hp.com/personal/Hans_Boehm/gc/"
+
+DEPENDS = "sed-native"
+SRC_URI = "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc6.5.tar.gz"
+S = "${WORKDIR}/gc6.5"
+FILES_${PN}-doc += "/usr/share/gc/"
+
+inherit autotools
+
+do_configure_append() {
+ #fix libtool script
+ sed -i 's:${SED}:sed:g' libtool
+ sed -i 's:$SED:sed:g' libtool
+}
+
+do_stage() {
+ autotools_stage_includes
+ install -d ${STAGING_LIBDIR}
+ install -m 755 .libs/libgc.so* ${STAGING_LIBDIR}/
+}