aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libgee
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libgee')
-rw-r--r--recipes/libgee/files/no-tests.patch12
-rw-r--r--recipes/libgee/libgee_0.1.4.bb19
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes/libgee/files/no-tests.patch b/recipes/libgee/files/no-tests.patch
new file mode 100644
index 0000000000..d2d20b2c4e
--- /dev/null
+++ b/recipes/libgee/files/no-tests.patch
@@ -0,0 +1,12 @@
+Index: libgee-0.1.2/Makefile.am
+===================================================================
+--- libgee-0.1.2.orig/Makefile.am
++++ libgee-0.1.2/Makefile.am
+@@ -4,7 +4,6 @@ NULL =
+
+ SUBDIRS = \
+ gee \
+- tests \
+ $(NULL)
+
+ pkgconfigdir = $(libdir)/pkgconfig
diff --git a/recipes/libgee/libgee_0.1.4.bb b/recipes/libgee/libgee_0.1.4.bb
new file mode 100644
index 0000000000..8e3a90599a
--- /dev/null
+++ b/recipes/libgee/libgee_0.1.4.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "libgee is a collection library providing GObject-based interfaces \
+and classes for commonly used data structures."
+HOMEPAGE = "http://live.gnome.org/Libgee"
+SECTION = "libs"
+DEPENDS = "glib-2.0"
+LICENSE = "LGPL"
+
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/libgee/0.1/libgee-${PV}.tar.bz2 \
+ file://no-tests.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+ install -d ${STAGING_DATADIR}/vala/vapi
+ install -m 0644 ${S}/gee/gee-1.0.vapi ${STAGING_DATADIR}/vala/vapi
+}
+
+FILES_${PN} += "${datadir}/vala"