summaryrefslogtreecommitdiffstats
path: root/recipes/libgphoto2/libgphoto2_2.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libgphoto2/libgphoto2_2.4.0.bb')
-rw-r--r--recipes/libgphoto2/libgphoto2_2.4.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/libgphoto2/libgphoto2_2.4.0.bb b/recipes/libgphoto2/libgphoto2_2.4.0.bb
new file mode 100644
index 0000000000..c6f63374cc
--- /dev/null
+++ b/recipes/libgphoto2/libgphoto2_2.4.0.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "libgphoto2 allows you to access digital cameras"
+
+SECTION = "libs"
+LICENSE = "GPL"
+DEPENDS = "libtool jpeg libusb libexif"
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2"
+
+inherit autotools pkgconfig lib_package
+
+OE_LT_RPATH_ALLOW=":${libdir}:"
+OE_LT_RPATH_ALLOW[export]="1"
+
+EXTRA_OECONF = " --with-drivers=all"
+
+PACKAGES =+ "libgphotoport libgphoto2-camlibs"
+FILES_libgphoto2-camlibs = "${libdir}/libgphoto2*/*/*.so*"
+RDEPENDS_${PN} = "libgphoto2-camlibs"
+
+FILES_libgphotoport = "${libdir}/libgphoto2_port.so.*"
+
+FILES_${PN} += "${libdir}/udev/*"
+FILES_${PN}-dbg += "${libdir}/*/*/.debug"
+
+do_stage() {
+ autotools_stage_all
+}
+
+