aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libid3tag
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libid3tag')
-rw-r--r--recipes/libid3tag/files/id3tag.pc11
-rw-r--r--recipes/libid3tag/libid3tag_0.15.1b.bb23
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes/libid3tag/files/id3tag.pc b/recipes/libid3tag/files/id3tag.pc
new file mode 100644
index 0000000000..e686000689
--- /dev/null
+++ b/recipes/libid3tag/files/id3tag.pc
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: id3tag
+Description: ID3 tag reading library
+Requires:
+Version: 0.15.0b
+Libs: -L${libdir} -lid3tag -lz
+Cflags: -I${includedir}
diff --git a/recipes/libid3tag/libid3tag_0.15.1b.bb b/recipes/libid3tag/libid3tag_0.15.1b.bb
new file mode 100644
index 0000000000..c9f4a0c0ba
--- /dev/null
+++ b/recipes/libid3tag/libid3tag_0.15.1b.bb
@@ -0,0 +1,23 @@
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "zlib"
+DESCRIPTION = "Library for interacting with ID3 tags."
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.mars.org/pub/mpeg/libid3tag-${PV}.tar.gz \
+ file://id3tag.pc"
+
+S = "${WORKDIR}/libid3tag-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "-enable-speed"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/id3tag.pc ${S}
+}
+do_stage() {
+ oe_libinstall -so libid3tag ${STAGING_LIBDIR}
+ install -m 0644 id3tag.h ${STAGING_INCDIR}
+}