aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libnl/libnl-1.1
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libnl/libnl-1.1')
-rw-r--r--recipes/libnl/libnl-1.1/dont-link-libnl-from-sysroot.patch26
-rw-r--r--recipes/libnl/libnl-1.1/fix-includes.patch13
-rw-r--r--recipes/libnl/libnl-1.1/local-includes.patch12
-rw-r--r--recipes/libnl/libnl-1.1/netlink-local-fix.patch12
-rw-r--r--recipes/libnl/libnl-1.1/respect-ldflags.patch12
5 files changed, 75 insertions, 0 deletions
diff --git a/recipes/libnl/libnl-1.1/dont-link-libnl-from-sysroot.patch b/recipes/libnl/libnl-1.1/dont-link-libnl-from-sysroot.patch
new file mode 100644
index 0000000000..beb63617ac
--- /dev/null
+++ b/recipes/libnl/libnl-1.1/dont-link-libnl-from-sysroot.patch
@@ -0,0 +1,26 @@
+Index: libnl-1.1/src/Makefile
+===================================================================
+--- libnl-1.1.orig/src/Makefile 2008-01-14 07:48:45.000000000 -0800
++++ libnl-1.1/src/Makefile 2010-09-22 14:58:46.820826001 -0700
+@@ -13,7 +13,7 @@ ifeq ($(shell [ ! -r ../Makefile.opts ]
+ include ../Makefile.opts
+ endif
+
+-LDFLAGS += -L../lib -lnl utils.o
++LDFLAGS += ../lib/libnl.so utils.o
+ CIN := $(wildcard nl-*.c) $(wildcard genl-*.c) $(wildcard nf-*.c)
+ TOOLS := $(CIN:%.c=%)
+
+Index: libnl-1.1/tests/Makefile
+===================================================================
+--- libnl-1.1.orig/tests/Makefile 2008-01-14 07:48:45.000000000 -0800
++++ libnl-1.1/tests/Makefile 2010-09-22 14:58:46.820826001 -0700
+@@ -13,7 +13,7 @@ ifeq ($(shell [ ! -r ../Makefile.opts ]
+ include ../Makefile.opts
+ endif
+
+-LDFLAGS += -L../lib -lnl ../src/utils.o
++LDFLAGS += ../lib/libnl.so ../src/utils.o
+ CIN := $(wildcard test-*.c)
+ TOOLS := $(CIN:%.c=%)
+
diff --git a/recipes/libnl/libnl-1.1/fix-includes.patch b/recipes/libnl/libnl-1.1/fix-includes.patch
new file mode 100644
index 0000000000..b172fd2f86
--- /dev/null
+++ b/recipes/libnl/libnl-1.1/fix-includes.patch
@@ -0,0 +1,13 @@
+diff -ruN libnl-1.1/lib/route/link/vlan.c libnl-1.1-new/lib/route/link/vlan.c
+--- libnl-1.1/lib/route/link/vlan.c 2008-01-14 18:48:45.000000000 +0300
++++ libnl-1.1-new/lib/route/link/vlan.c 2009-01-30 10:55:09.000000000 +0300
+@@ -26,7 +26,9 @@
+ #include <netlink/route/link/info-api.h>
+ #include <netlink/route/link/vlan.h>
+
++#ifndef VLAN_FLAG_REORDER_HDR
+ #include <linux/if_vlan.h>
++#endif
+
+ /** @cond SKIP */
+ #define VLAN_HAS_ID (1<<0)
diff --git a/recipes/libnl/libnl-1.1/local-includes.patch b/recipes/libnl/libnl-1.1/local-includes.patch
new file mode 100644
index 0000000000..85659db6d7
--- /dev/null
+++ b/recipes/libnl/libnl-1.1/local-includes.patch
@@ -0,0 +1,12 @@
+diff -urN libnl-1.1.orig/Makefile.opts.in libnl-1.1/Makefile.opts.in
+--- libnl-1.1.orig/Makefile.opts.in 2008-01-14 15:48:45.000000000 +0000
++++ libnl-1.1/Makefile.opts.in 2009-04-06 10:20:40.000000000 +0000
+@@ -10,7 +10,7 @@
+ #
+
+ CC := @CC@
+-CFLAGS := @CFLAGS@
++CFLAGS := -I./include -I. -I../include @CFLAGS@
+ LDFLAGS := @LDFLAGS@
+ CPPFLAGS := @CPPFLAGS@
+ PACKAGE_NAME := @PACKAGE_NAME@
diff --git a/recipes/libnl/libnl-1.1/netlink-local-fix.patch b/recipes/libnl/libnl-1.1/netlink-local-fix.patch
new file mode 100644
index 0000000000..51c6736025
--- /dev/null
+++ b/recipes/libnl/libnl-1.1/netlink-local-fix.patch
@@ -0,0 +1,12 @@
+Index: libnl-1.1/include/netlink-local.h
+===================================================================
+--- libnl-1.1.orig/include/netlink-local.h 2009-06-18 15:28:32.614209645 +0400
++++ libnl-1.1/include/netlink-local.h 2009-06-18 15:28:44.094190518 +0400
+@@ -26,6 +26,7 @@
+ #include <sys/socket.h>
+ #include <inttypes.h>
+ #include <assert.h>
++#include <limits.h>
+
+ #include <arpa/inet.h>
+ #include <netdb.h>
diff --git a/recipes/libnl/libnl-1.1/respect-ldflags.patch b/recipes/libnl/libnl-1.1/respect-ldflags.patch
new file mode 100644
index 0000000000..ba97dc6724
--- /dev/null
+++ b/recipes/libnl/libnl-1.1/respect-ldflags.patch
@@ -0,0 +1,12 @@
+diff -urN libnl-1.1.orig/lib/Makefile libnl-1.1/lib/Makefile
+--- libnl-1.1.orig/lib/Makefile 2008-01-14 15:48:45.000000000 +0000
++++ libnl-1.1/lib/Makefile 2009-04-06 10:16:21.000000000 +0000
+@@ -48,7 +48,7 @@
+
+ $(OUT_SLIB): ../Makefile.opts $(OBJ)
+ @echo " LD $(OUT_SLIB)"; \
+- $(CC) -shared -Wl,-soname,libnl.so.1 -o $(OUT_SLIB) $(OBJ) $(LIBNL_LIB) -lc
++ $(CC) $(LDFLAGS) -shared -Wl,-soname,libnl.so.1 -o $(OUT_SLIB) $(OBJ) $(LIBNL_LIB) -lc
+ @echo " LN $(OUT_SLIB) $(LN1_SLIB)"; \
+ rm -f $(LN1_SLIB) ; $(LN) -s $(OUT_SLIB) $(LN1_SLIB)
+ @echo " LN $(LN1_SLIB) $(LN_SLIB)"; \