aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libnl/libnl2/fix-pktloc_syntax_h-race.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libnl/libnl2/fix-pktloc_syntax_h-race.patch')
-rw-r--r--recipes/libnl/libnl2/fix-pktloc_syntax_h-race.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/libnl/libnl2/fix-pktloc_syntax_h-race.patch b/recipes/libnl/libnl2/fix-pktloc_syntax_h-race.patch
new file mode 100644
index 0000000000..d396f963b4
--- /dev/null
+++ b/recipes/libnl/libnl2/fix-pktloc_syntax_h-race.patch
@@ -0,0 +1,23 @@
+---
+ lib/Makefile.am | 3 +++
+ 1 file changed, 3 insertions(+)
+
+Index: libnl-2.0/lib/Makefile.am
+===================================================================
+--- libnl-2.0.orig/lib/Makefile.am
++++ libnl-2.0/lib/Makefile.am
+@@ -27,11 +27,14 @@ CLEANFILES = \
+ route/pktloc_grammar.c route/pktloc_grammar.h \
+ route/pktloc_syntax.c route/pktloc_syntax.h
+
++BUILT_SOURCES = route/pktloc_syntax.h
++
+ # Hack to avoid using ylwrap. It does not function correctly in combination
+ # with --header-file=
+ route/pktloc_grammar.c: route/pktloc_grammar.l
+ $(LEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
+
++route/pktloc_syntax.h: route/pktloc_syntax.c
+ route/pktloc_syntax.c: route/pktloc_syntax.y
+ $(YACC) -d $(YFLAGS) -o $@ $^
+