aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libogg/libogg_1.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libogg/libogg_1.1.3.bb')
-rw-r--r--recipes/libogg/libogg_1.1.3.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/libogg/libogg_1.1.3.bb b/recipes/libogg/libogg_1.1.3.bb
new file mode 100644
index 0000000000..0a6e827ff1
--- /dev/null
+++ b/recipes/libogg/libogg_1.1.3.bb
@@ -0,0 +1,17 @@
+SECTION = "libs"
+DESCRIPTION = "libogg is the bitstream and framing library \
+for the Ogg project. It provides functions which are \
+necessary to codec libraries like libvorbis."
+LICENSE = "BSD"
+
+SRC_URI = "http://downloads.xiph.org/releases/ogg/libogg-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/ogg
+ (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
+ install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
+}