summaryrefslogtreecommitdiffstats
path: root/recipes/libogg
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libogg')
-rw-r--r--recipes/libogg/libogg.inc11
-rw-r--r--recipes/libogg/libogg_1.0.bb18
-rw-r--r--recipes/libogg/libogg_1.1.3.bb17
-rw-r--r--recipes/libogg/libogg_1.1.4.bb4
-rw-r--r--recipes/libogg/libogg_1.1.bb19
-rw-r--r--recipes/libogg/libtheora-1.0/libtheora-1.0-no-docs.patch33
-rw-r--r--recipes/libogg/libtheora_0.9+1.0alpha7.bb19
-rw-r--r--recipes/libogg/libtheora_1.0.bb23
8 files changed, 22 insertions, 122 deletions
diff --git a/recipes/libogg/libogg.inc b/recipes/libogg/libogg.inc
new file mode 100644
index 0000000000..f8eed60fef
--- /dev/null
+++ b/recipes/libogg/libogg.inc
@@ -0,0 +1,11 @@
+SECTION = "libs"
+DESCRIPTION = "libogg is the bitstream and framing library \
+for the Ogg project. It provides functions which are \
+necessary to codec libraries like libvorbis."
+LICENSE = "BSD"
+
+INC_PR = "r4"
+
+inherit autotools
+
+SRC_URI = "http://downloads.xiph.org/releases/ogg/libogg-${PV}.tar.gz"
diff --git a/recipes/libogg/libogg_1.0.bb b/recipes/libogg/libogg_1.0.bb
index 7af1468004..d5bad18a0a 100644
--- a/recipes/libogg/libogg_1.0.bb
+++ b/recipes/libogg/libogg_1.0.bb
@@ -1,18 +1,4 @@
-SECTION = "libs"
-DESCRIPTION = "libogg is the bitstream and framing library \
-for the Ogg project. It provides functions which are \
-necessary to codec libraries like libvorbis."
-LICENSE = "BSD"
-PR = "r1"
+require libogg.inc
-SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libogg-${PV}.tar.gz"
+PR = "${INC_PR}.0"
-inherit autotools pkgconfig
-
-do_stage () {
- oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/ogg
- (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
- install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
-}
diff --git a/recipes/libogg/libogg_1.1.3.bb b/recipes/libogg/libogg_1.1.3.bb
index 0a6e827ff1..d5bad18a0a 100644
--- a/recipes/libogg/libogg_1.1.3.bb
+++ b/recipes/libogg/libogg_1.1.3.bb
@@ -1,17 +1,4 @@
-SECTION = "libs"
-DESCRIPTION = "libogg is the bitstream and framing library \
-for the Ogg project. It provides functions which are \
-necessary to codec libraries like libvorbis."
-LICENSE = "BSD"
+require libogg.inc
-SRC_URI = "http://downloads.xiph.org/releases/ogg/libogg-${PV}.tar.gz"
+PR = "${INC_PR}.0"
-inherit autotools pkgconfig
-
-do_stage () {
- oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/ogg
- (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
- install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
-}
diff --git a/recipes/libogg/libogg_1.1.4.bb b/recipes/libogg/libogg_1.1.4.bb
new file mode 100644
index 0000000000..d5bad18a0a
--- /dev/null
+++ b/recipes/libogg/libogg_1.1.4.bb
@@ -0,0 +1,4 @@
+require libogg.inc
+
+PR = "${INC_PR}.0"
+
diff --git a/recipes/libogg/libogg_1.1.bb b/recipes/libogg/libogg_1.1.bb
index 687b4decec..0baec126e3 100644
--- a/recipes/libogg/libogg_1.1.bb
+++ b/recipes/libogg/libogg_1.1.bb
@@ -1,19 +1,6 @@
-SECTION = "libs"
-DESCRIPTION = "libogg is the bitstream and framing library \
-for the Ogg project. It provides functions which are \
-necessary to codec libraries like libvorbis."
-LICENSE = "BSD"
-PR = "r3"
+require libogg.inc
-SRC_URI = "http://www.vorbis.com/files/1.0.1/unix/libogg-${PV}.tar.gz \
-file://m4.patch;patch=1"
+PR = "${INC_PR}.0"
-inherit autotools pkgconfig
+SRC_URI += "file://m4.patch;patch=1"
-do_stage () {
- oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/ogg
- (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
- install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
-}
diff --git a/recipes/libogg/libtheora-1.0/libtheora-1.0-no-docs.patch b/recipes/libogg/libtheora-1.0/libtheora-1.0-no-docs.patch
deleted file mode 100644
index ce1fa70940..0000000000
--- a/recipes/libogg/libtheora-1.0/libtheora-1.0-no-docs.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -urN libtheora-1.0-0rig/Makefile.am libtheora-1.0/Makefile.am
---- libtheora-1.0-0rig//Makefile.am 2008-10-21 05:36:32.000000000 +0200
-+++ libtheora-1.0/Makefile.am 2009-03-16 18:16:32.000000000 +0100
-@@ -8,7 +8,7 @@
- EXAMPLES_DIR =
- endif
-
--SUBDIRS = lib include doc tests m4 $(EXAMPLES_DIR)
-+SUBDIRS = lib include m4 $(EXAMPLES_DIR)
-
-
- # we include the whole debian/ dir in EXTRA_DIST because there's a problem
-diff -urN libtheora-1.0-0rig//Makefile.in libtheora-1.0/Makefile.in
---- libtheora-1.0-0rig//Makefile.in 2008-10-29 11:36:48.000000000 +0100
-+++ libtheora-1.0/Makefile.in 2009-03-16 18:16:51.000000000 +0100
-@@ -80,7 +80,7 @@
- DATA = $(pkgconfig_DATA)
- ETAGS = etags
- CTAGS = ctags
--DIST_SUBDIRS = lib include doc tests m4 examples
-+DIST_SUBDIRS = lib include m4 examples
- DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
- distdir = $(PACKAGE)-$(VERSION)
- top_distdir = $(distdir)
-@@ -262,7 +262,7 @@
- AUTOMAKE_OPTIONS = foreign 1.6 dist-zip dist-bzip2
- @THEORA_ENABLE_EXAMPLES_FALSE@EXAMPLES_DIR =
- @THEORA_ENABLE_EXAMPLES_TRUE@EXAMPLES_DIR = examples
--SUBDIRS = lib include doc tests m4 $(EXAMPLES_DIR)
-+SUBDIRS = lib include m4 $(EXAMPLES_DIR)
-
- # we include the whole debian/ dir in EXTRA_DIST because there's a problem
- # with autotools and HFS+ MacOSX file systems that caused debian/Makefile.am
diff --git a/recipes/libogg/libtheora_0.9+1.0alpha7.bb b/recipes/libogg/libtheora_0.9+1.0alpha7.bb
deleted file mode 100644
index 5a372b65a1..0000000000
--- a/recipes/libogg/libtheora_0.9+1.0alpha7.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-
-DEPENDS = "libogg libvorbis libsdl-x11"
-
-SRC_URI = "http://downloads.xiph.org/releases/theora/libtheora-1.0alpha7.tar.gz"
-
-S = "${WORKDIR}/libtheora-1.0alpha7"
-
-inherit autotools pkgconfig lib_package
-
-
-do_configure_append() {
- find ${S} -name Makefile | xargs sed -i -e s:'-I/usr/include':-I${STAGING_INCDIR}:g
-}
-
-do_stage() {
- autotools_stage_all
-}
-
-
diff --git a/recipes/libogg/libtheora_1.0.bb b/recipes/libogg/libtheora_1.0.bb
deleted file mode 100644
index 431ed39525..0000000000
--- a/recipes/libogg/libtheora_1.0.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-
-DEPENDS = "libogg libvorbis"
-
-PR = "r3"
-
-SRC_URI = "http://downloads.xiph.org/releases/theora/libtheora-${PV}.tar.bz2 \
- file://libtheora-1.0-no-docs.patch;patch=1"
-
-inherit autotools lib_package
-
-EXTRA_OECONF = "--disable-examples"
-
-LEAD_SONAME = "libtheora.so.0"
-
-do_configure_append() {
- find ${S} -name Makefile | xargs sed -i -e s:'-I/usr/include':-I${STAGING_INCDIR}:g
-}
-
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-
-do_stage() {
- autotools_stage_all
-}