summaryrefslogtreecommitdiffstats
path: root/recipes/libogg
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libogg')
-rw-r--r--recipes/libogg/libogg/m4.patch11
-rw-r--r--recipes/libogg/libogg_1.0.bb18
-rw-r--r--recipes/libogg/libogg_1.1.3.bb17
-rw-r--r--recipes/libogg/libogg_1.1.bb19
-rw-r--r--recipes/libogg/libtheora_0.9+1.0alpha7.bb19
-rw-r--r--recipes/libogg/libtheora_1.0.bb18
6 files changed, 102 insertions, 0 deletions
diff --git a/recipes/libogg/libogg/m4.patch b/recipes/libogg/libogg/m4.patch
new file mode 100644
index 0000000000..66239f4f68
--- /dev/null
+++ b/recipes/libogg/libogg/m4.patch
@@ -0,0 +1,11 @@
+--- libogg-1.1/ogg.m4.orig 2003-03-08 03:44:29 +0100
++++ libogg-1.1/ogg.m4 2004-08-12 11:26:46 +0200
+@@ -5,7 +5,7 @@
+ dnl XIPH_PATH_OGG([ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
+ dnl Test for libogg, and define OGG_CFLAGS and OGG_LIBS
+ dnl
+-AC_DEFUN(XIPH_PATH_OGG,
++AC_DEFUN([XIPH_PATH_OGG],
+ [dnl
+ dnl Get the cflags and libraries
+ dnl
diff --git a/recipes/libogg/libogg_1.0.bb b/recipes/libogg/libogg_1.0.bb
new file mode 100644
index 0000000000..7af1468004
--- /dev/null
+++ b/recipes/libogg/libogg_1.0.bb
@@ -0,0 +1,18 @@
+SECTION = "libs"
+DESCRIPTION = "libogg is the bitstream and framing library \
+for the Ogg project. It provides functions which are \
+necessary to codec libraries like libvorbis."
+LICENSE = "BSD"
+PR = "r1"
+
+SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libogg-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/ogg
+ (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
+ install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
+}
diff --git a/recipes/libogg/libogg_1.1.3.bb b/recipes/libogg/libogg_1.1.3.bb
new file mode 100644
index 0000000000..0a6e827ff1
--- /dev/null
+++ b/recipes/libogg/libogg_1.1.3.bb
@@ -0,0 +1,17 @@
+SECTION = "libs"
+DESCRIPTION = "libogg is the bitstream and framing library \
+for the Ogg project. It provides functions which are \
+necessary to codec libraries like libvorbis."
+LICENSE = "BSD"
+
+SRC_URI = "http://downloads.xiph.org/releases/ogg/libogg-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/ogg
+ (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
+ install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
+}
diff --git a/recipes/libogg/libogg_1.1.bb b/recipes/libogg/libogg_1.1.bb
new file mode 100644
index 0000000000..687b4decec
--- /dev/null
+++ b/recipes/libogg/libogg_1.1.bb
@@ -0,0 +1,19 @@
+SECTION = "libs"
+DESCRIPTION = "libogg is the bitstream and framing library \
+for the Ogg project. It provides functions which are \
+necessary to codec libraries like libvorbis."
+LICENSE = "BSD"
+PR = "r3"
+
+SRC_URI = "http://www.vorbis.com/files/1.0.1/unix/libogg-${PV}.tar.gz \
+file://m4.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/ogg
+ (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
+ install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
+}
diff --git a/recipes/libogg/libtheora_0.9+1.0alpha7.bb b/recipes/libogg/libtheora_0.9+1.0alpha7.bb
new file mode 100644
index 0000000000..5a372b65a1
--- /dev/null
+++ b/recipes/libogg/libtheora_0.9+1.0alpha7.bb
@@ -0,0 +1,19 @@
+
+DEPENDS = "libogg libvorbis libsdl-x11"
+
+SRC_URI = "http://downloads.xiph.org/releases/theora/libtheora-1.0alpha7.tar.gz"
+
+S = "${WORKDIR}/libtheora-1.0alpha7"
+
+inherit autotools pkgconfig lib_package
+
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i -e s:'-I/usr/include':-I${STAGING_INCDIR}:g
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/libogg/libtheora_1.0.bb b/recipes/libogg/libtheora_1.0.bb
new file mode 100644
index 0000000000..55d3e83beb
--- /dev/null
+++ b/recipes/libogg/libtheora_1.0.bb
@@ -0,0 +1,18 @@
+
+DEPENDS = "libogg libvorbis libsdl-x11"
+
+SRC_URI = "http://downloads.xiph.org/releases/theora/libtheora-${PV}.tar.bz2"
+
+inherit autotools lib_package
+
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i -e s:'-I/usr/include':-I${STAGING_INCDIR}:g
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+do_stage() {
+ autotools_stage_all
+}
+
+