summaryrefslogtreecommitdiffstats
path: root/recipes/librsync
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/librsync')
-rw-r--r--recipes/librsync/librsync_0.9.7.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/librsync/librsync_0.9.7.bb b/recipes/librsync/librsync_0.9.7.bb
new file mode 100644
index 0000000000..eb8bb2671c
--- /dev/null
+++ b/recipes/librsync/librsync_0.9.7.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "librsync is a free software library that implements the rsync \
+remote-delta algorithm. This algorithm allows efficient remote updates of a \
+file, without requiring the old and new versions to both be present at the \
+sending end."
+HOMEPAGE = "http://librsync.sourceforge.net/"
+SECTION = "libs"
+LICENSE = "LGPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/librsync/librsync-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-build-docs --enable-shared "
+
+do_stage() {
+ oe_libinstall -a -so -C .libs librsync ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/
+ for i in librsync.h librsync-config.h
+ do
+ install -m 0644 ${S}/$i ${STAGING_INCDIR}/$i
+ done
+}