aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsdl/libsdl-image_1.2.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libsdl/libsdl-image_1.2.10.bb')
-rw-r--r--recipes/libsdl/libsdl-image_1.2.10.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/libsdl/libsdl-image_1.2.10.bb b/recipes/libsdl/libsdl-image_1.2.10.bb
new file mode 100644
index 0000000000..bda06456b3
--- /dev/null
+++ b/recipes/libsdl/libsdl-image_1.2.10.bb
@@ -0,0 +1,16 @@
+require libsdl-image.inc
+
+PR = "${INC_PR}.1"
+
+DEPENDS += "tiff"
+
+# Disable the run-time loading of the libs and bring back the soname dependencies.
+EXTRA_OECONF += "--disable-jpg-shared --disable-png-shared -disable-tif-shared"
+
+do_unpackpost() {
+ # Removing this file fixes a libtool version mismatch.
+ rm acinclude/libtool.m4
+ rm acinclude/sdl.m4
+}
+
+addtask unpackpost after do_unpack before do_patch