aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsdl/libsdl-mixer_1.2.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libsdl/libsdl-mixer_1.2.11.bb')
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.11.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes/libsdl/libsdl-mixer_1.2.11.bb b/recipes/libsdl/libsdl-mixer_1.2.11.bb
index 8c032ceb03..498f3591c5 100644
--- a/recipes/libsdl/libsdl-mixer_1.2.11.bb
+++ b/recipes/libsdl/libsdl-mixer_1.2.11.bb
@@ -1,10 +1,10 @@
DESCRIPTION = "Simple DirectMedia Layer mixer library."
SECTION = "libs"
PRIORITY = "optional"
-DEPENDS = "virtual/libsdl flac libmikmod libvorbis libmad"
+DEPENDS = "virtual/libsdl flac libmikmod libvorbis ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
LICENSE = "LGPL"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
file://fix-flac-madness.diff"
@@ -20,7 +20,7 @@ inherit autotools
# Add support for runtime linking with libmad so we can use that for fixed point MP3 decoding.
# Add support for runtime linking with libtremor so we can use that for fixed point OGG Vorbis decoding.
-EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor --enable-music-mp3-mad-gpl LIBS=-L${STAGING_LIBDIR}"
+EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-music-mp3-mad-gpl', d)} LIBS=-L${STAGING_LIBDIR}"
do_compile() {
# Override SDL_LIBS to include a linker rpath so the linker