aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsexy
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libsexy')
-rw-r--r--recipes/libsexy/files/libsexy-pkgconfig-fixes.patch15
-rw-r--r--recipes/libsexy/libsexy.inc17
-rw-r--r--recipes/libsexy/libsexy_0.1.10.bb2
-rw-r--r--recipes/libsexy/libsexy_0.1.11.bb2
-rw-r--r--recipes/libsexy/libsexy_0.1.6.bb2
-rw-r--r--recipes/libsexy/libsexy_0.1.8.bb2
6 files changed, 40 insertions, 0 deletions
diff --git a/recipes/libsexy/files/libsexy-pkgconfig-fixes.patch b/recipes/libsexy/files/libsexy-pkgconfig-fixes.patch
new file mode 100644
index 0000000000..61da9474df
--- /dev/null
+++ b/recipes/libsexy/files/libsexy-pkgconfig-fixes.patch
@@ -0,0 +1,15 @@
+Index: libsexy-0.1.11/libsexy.pc.in
+===================================================================
+--- libsexy-0.1.11.orig/libsexy.pc.in 2005-11-10 10:21:18.000000000 +0000
++++ libsexy-0.1.11/libsexy.pc.in 2008-03-05 14:36:39.000000000 +0000
+@@ -6,7 +6,8 @@
+ Name: libsexy
+ Description: Doing naughty things to good widgets
+ Version: @VERSION@
+-Libs: -L${libdir} -lsexy @PACKAGE_LIBS@
+-Cflags: -I${includedir} @PACKAGE_CFLAGS@
+
++Requires: pango glib-2.0 gtk+-2.0 libxml-2.0
++Libs: -L${libdir} -lsexy
++Cflags: -I${includedir}
+
diff --git a/recipes/libsexy/libsexy.inc b/recipes/libsexy/libsexy.inc
new file mode 100644
index 0000000000..27816c0800
--- /dev/null
+++ b/recipes/libsexy/libsexy.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "Libsexy is a collection of GTK+ widgets that extend the functionality of such standard widgets as GtkEntry and GtkLabel"
+HOMEPAGE = "http://wiki.chipx86.com/wiki/Libsexy"
+AUTHOR = "Christian Hammond <chipx86@chipx86.com>"
+SECTION = "x11/libs"
+
+DEPENDS = "gtk+ enchant libxml2"
+
+SRC_URI = "http://releases.chipx86.com/libsexy/${PN}/${PN}-${PV}.tar.gz \
+ file://libsexy-pkgconfig-fixes.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_stage() {
+autotools_stage_all
+}
+
+
diff --git a/recipes/libsexy/libsexy_0.1.10.bb b/recipes/libsexy/libsexy_0.1.10.bb
new file mode 100644
index 0000000000..042ea757e9
--- /dev/null
+++ b/recipes/libsexy/libsexy_0.1.10.bb
@@ -0,0 +1,2 @@
+require libsexy.inc
+PR = "r0"
diff --git a/recipes/libsexy/libsexy_0.1.11.bb b/recipes/libsexy/libsexy_0.1.11.bb
new file mode 100644
index 0000000000..91784ffb49
--- /dev/null
+++ b/recipes/libsexy/libsexy_0.1.11.bb
@@ -0,0 +1,2 @@
+require libsexy.inc
+PR = "r1"
diff --git a/recipes/libsexy/libsexy_0.1.6.bb b/recipes/libsexy/libsexy_0.1.6.bb
new file mode 100644
index 0000000000..042ea757e9
--- /dev/null
+++ b/recipes/libsexy/libsexy_0.1.6.bb
@@ -0,0 +1,2 @@
+require libsexy.inc
+PR = "r0"
diff --git a/recipes/libsexy/libsexy_0.1.8.bb b/recipes/libsexy/libsexy_0.1.8.bb
new file mode 100644
index 0000000000..91784ffb49
--- /dev/null
+++ b/recipes/libsexy/libsexy_0.1.8.bb
@@ -0,0 +1,2 @@
+require libsexy.inc
+PR = "r1"