aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb')
-rw-r--r--recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb b/recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb
new file mode 100644
index 0000000000..61d34840c9
--- /dev/null
+++ b/recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "A library for loose coupling of C++ method calls"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL"
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/libsigc++-${PV}.tar.gz \
+ "
+
+S = "${WORKDIR}/libsigc++-${PV}"
+
+inherit autotools
+
+EXTRA_AUTORECONF = "--exclude=autoheader"
+
+FILES_${PN}-dev += "${libdir}/sigc++-*/"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+