aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtheora
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libtheora')
-rw-r--r--recipes/libtheora/libtheora-1.0/libtheora-1.0-no-docs.patch33
-rw-r--r--recipes/libtheora/libtheora-1.1.1/no-docs.patch13
-rw-r--r--recipes/libtheora/libtheora.inc17
-rw-r--r--recipes/libtheora/libtheora_0.9+1.0alpha7.bb19
-rw-r--r--recipes/libtheora/libtheora_1.0.bb6
-rw-r--r--recipes/libtheora/libtheora_1.1.1.bb6
6 files changed, 94 insertions, 0 deletions
diff --git a/recipes/libtheora/libtheora-1.0/libtheora-1.0-no-docs.patch b/recipes/libtheora/libtheora-1.0/libtheora-1.0-no-docs.patch
new file mode 100644
index 0000000000..ce1fa70940
--- /dev/null
+++ b/recipes/libtheora/libtheora-1.0/libtheora-1.0-no-docs.patch
@@ -0,0 +1,33 @@
+diff -urN libtheora-1.0-0rig/Makefile.am libtheora-1.0/Makefile.am
+--- libtheora-1.0-0rig//Makefile.am 2008-10-21 05:36:32.000000000 +0200
++++ libtheora-1.0/Makefile.am 2009-03-16 18:16:32.000000000 +0100
+@@ -8,7 +8,7 @@
+ EXAMPLES_DIR =
+ endif
+
+-SUBDIRS = lib include doc tests m4 $(EXAMPLES_DIR)
++SUBDIRS = lib include m4 $(EXAMPLES_DIR)
+
+
+ # we include the whole debian/ dir in EXTRA_DIST because there's a problem
+diff -urN libtheora-1.0-0rig//Makefile.in libtheora-1.0/Makefile.in
+--- libtheora-1.0-0rig//Makefile.in 2008-10-29 11:36:48.000000000 +0100
++++ libtheora-1.0/Makefile.in 2009-03-16 18:16:51.000000000 +0100
+@@ -80,7 +80,7 @@
+ DATA = $(pkgconfig_DATA)
+ ETAGS = etags
+ CTAGS = ctags
+-DIST_SUBDIRS = lib include doc tests m4 examples
++DIST_SUBDIRS = lib include m4 examples
+ DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+ distdir = $(PACKAGE)-$(VERSION)
+ top_distdir = $(distdir)
+@@ -262,7 +262,7 @@
+ AUTOMAKE_OPTIONS = foreign 1.6 dist-zip dist-bzip2
+ @THEORA_ENABLE_EXAMPLES_FALSE@EXAMPLES_DIR =
+ @THEORA_ENABLE_EXAMPLES_TRUE@EXAMPLES_DIR = examples
+-SUBDIRS = lib include doc tests m4 $(EXAMPLES_DIR)
++SUBDIRS = lib include m4 $(EXAMPLES_DIR)
+
+ # we include the whole debian/ dir in EXTRA_DIST because there's a problem
+ # with autotools and HFS+ MacOSX file systems that caused debian/Makefile.am
diff --git a/recipes/libtheora/libtheora-1.1.1/no-docs.patch b/recipes/libtheora/libtheora-1.1.1/no-docs.patch
new file mode 100644
index 0000000000..5734bce465
--- /dev/null
+++ b/recipes/libtheora/libtheora-1.1.1/no-docs.patch
@@ -0,0 +1,13 @@
+Index: libtheora-1.1.1/Makefile.am
+===================================================================
+--- libtheora-1.1.1.orig/Makefile.am 2009-11-25 22:01:53.593775926 +0100
++++ libtheora-1.1.1/Makefile.am 2009-11-25 22:02:00.777524017 +0100
+@@ -8,7 +8,7 @@
+ EXAMPLES_DIR =
+ endif
+
+-SUBDIRS = lib include doc tests m4 $(EXAMPLES_DIR)
++SUBDIRS = lib include tests m4 $(EXAMPLES_DIR)
+
+
+ # we include the whole debian/ dir in EXTRA_DIST because there's a problem
diff --git a/recipes/libtheora/libtheora.inc b/recipes/libtheora/libtheora.inc
new file mode 100644
index 0000000000..d288e7af06
--- /dev/null
+++ b/recipes/libtheora/libtheora.inc
@@ -0,0 +1,17 @@
+SECTION = "libs"
+DESCRIPTION = "theora is a high-quality video codec \
+that is free of intellectual property restrictions"
+LICENSE = "BSD"
+
+DEPENDS = "pkgconfig libogg"
+
+INC_PR = "r3"
+
+SRC_URI = "http://downloads.xiph.org/releases/theora/libtheora-${PV}.tar.bz2"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-examples"
+
+LEAD_SONAME = "libtheora.so.0"
+
diff --git a/recipes/libtheora/libtheora_0.9+1.0alpha7.bb b/recipes/libtheora/libtheora_0.9+1.0alpha7.bb
new file mode 100644
index 0000000000..5a372b65a1
--- /dev/null
+++ b/recipes/libtheora/libtheora_0.9+1.0alpha7.bb
@@ -0,0 +1,19 @@
+
+DEPENDS = "libogg libvorbis libsdl-x11"
+
+SRC_URI = "http://downloads.xiph.org/releases/theora/libtheora-1.0alpha7.tar.gz"
+
+S = "${WORKDIR}/libtheora-1.0alpha7"
+
+inherit autotools pkgconfig lib_package
+
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i -e s:'-I/usr/include':-I${STAGING_INCDIR}:g
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/libtheora/libtheora_1.0.bb b/recipes/libtheora/libtheora_1.0.bb
new file mode 100644
index 0000000000..01de01d138
--- /dev/null
+++ b/recipes/libtheora/libtheora_1.0.bb
@@ -0,0 +1,6 @@
+require libtheora.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI += "file://libtheora-1.0-no-docs.patch;patch=1"
+
diff --git a/recipes/libtheora/libtheora_1.1.1.bb b/recipes/libtheora/libtheora_1.1.1.bb
new file mode 100644
index 0000000000..34bbb0bcbf
--- /dev/null
+++ b/recipes/libtheora/libtheora_1.1.1.bb
@@ -0,0 +1,6 @@
+require libtheora.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI += "file://no-docs.patch;patch=1"
+