aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtomcrypt/libtomcrypt_1.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libtomcrypt/libtomcrypt_1.17.bb')
-rw-r--r--recipes/libtomcrypt/libtomcrypt_1.17.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/libtomcrypt/libtomcrypt_1.17.bb b/recipes/libtomcrypt/libtomcrypt_1.17.bb
new file mode 100644
index 0000000000..1d0c664464
--- /dev/null
+++ b/recipes/libtomcrypt/libtomcrypt_1.17.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "LibTomCrypt is a fairly comprehensive, modular \
+and portable cryptographic toolkit that provides developers \
+with a vast array of well known published block ciphers, \
+one-way hash functions, chaining modes, pseudo-random number \
+generators, public key cryptography and a plethora of other \
+routines."
+SECTION = "libs/network"
+PRIORITY = "optional"
+LICENSE = "PD"
+PR = "r0"
+
+SRC_URI = "http://libtom.org/files/crypt-${PV}.tar.bz2"
+
+inherit autotools
+
+EXTRA_OEMAKE = "library"
+
+#FIXME add patch to make it shared
+
+do_stage() {
+ oe_libinstall -a libtomcrypt ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/src/headers/*.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ :
+}