aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtorrent
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libtorrent')
-rw-r--r--recipes/libtorrent/files/autoconf-cross-fix.patch14
-rw-r--r--recipes/libtorrent/libtorrent_0.12.0.bb16
-rw-r--r--recipes/libtorrent/libtorrent_0.12.3.bb16
-rw-r--r--recipes/libtorrent/libtorrent_0.12.4.bb17
-rw-r--r--recipes/libtorrent/rtorrent_0.8.0.bb11
-rw-r--r--recipes/libtorrent/rtorrent_0.8.3.bb11
-rw-r--r--recipes/libtorrent/rtorrent_0.8.4.bb13
7 files changed, 98 insertions, 0 deletions
diff --git a/recipes/libtorrent/files/autoconf-cross-fix.patch b/recipes/libtorrent/files/autoconf-cross-fix.patch
new file mode 100644
index 0000000000..a8dd3a5b76
--- /dev/null
+++ b/recipes/libtorrent/files/autoconf-cross-fix.patch
@@ -0,0 +1,14 @@
+Index: rtorrent-0.8.0/scripts/common.m4
+===================================================================
+--- rtorrent-0.8.0.orig/scripts/common.m4 2008-01-13 15:02:03.000000000 +0000
++++ rtorrent-0.8.0/scripts/common.m4 2008-02-04 13:12:01.000000000 +0000
+@@ -192,6 +192,9 @@
+ AC_DEFINE(USE_EXECINFO, 1, Use execinfo.h)
+ ], [
+ AC_MSG_RESULT(no)
++ ], [
++ AC_MSG_RESULT(yes)
++ AC_DEFINE(USE_EXECINFO, 1, Use execinfo.h)
+ ])
+ ])
+
diff --git a/recipes/libtorrent/libtorrent_0.12.0.bb b/recipes/libtorrent/libtorrent_0.12.0.bb
new file mode 100644
index 0000000000..5d711578ed
--- /dev/null
+++ b/recipes/libtorrent/libtorrent_0.12.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "library implementing the bittorrent protocol"
+HOMEPAGE = "http://libtorrent.rakshasa.no"
+SECTION = "libs/network"
+LICENSE = "GPL"
+DEPENDS = "libsigc++-2.0 openssl"
+
+SRC_URI = "http://libtorrent.rakshasa.no/downloads/libtorrent-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-aligned"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/libtorrent/libtorrent_0.12.3.bb b/recipes/libtorrent/libtorrent_0.12.3.bb
new file mode 100644
index 0000000000..5d711578ed
--- /dev/null
+++ b/recipes/libtorrent/libtorrent_0.12.3.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "library implementing the bittorrent protocol"
+HOMEPAGE = "http://libtorrent.rakshasa.no"
+SECTION = "libs/network"
+LICENSE = "GPL"
+DEPENDS = "libsigc++-2.0 openssl"
+
+SRC_URI = "http://libtorrent.rakshasa.no/downloads/libtorrent-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-aligned"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/libtorrent/libtorrent_0.12.4.bb b/recipes/libtorrent/libtorrent_0.12.4.bb
new file mode 100644
index 0000000000..9673e5bdcb
--- /dev/null
+++ b/recipes/libtorrent/libtorrent_0.12.4.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "library implementing the bittorrent protocol"
+HOMEPAGE = "http://libtorrent.rakshasa.no"
+SECTION = "libs/network"
+LICENSE = "GPL"
+DEPENDS = "libsigc++-2.0 openssl"
+
+SRC_URI = "http://libtorrent.rakshasa.no/downloads/libtorrent-${PV}.tar.gz"
+PR = "r0"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-aligned"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/libtorrent/rtorrent_0.8.0.bb b/recipes/libtorrent/rtorrent_0.8.0.bb
new file mode 100644
index 0000000000..9ae0eed011
--- /dev/null
+++ b/recipes/libtorrent/rtorrent_0.8.0.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Console bittorrent client using libtorrent"
+HOMEPAGE = "http://libtorrent.rakshasa.no"
+SECTION = "libs/network"
+LICENSE = "GPL"
+DEPENDS = "libtorrent curl ncurses gnutls libgpg-error"
+
+SRC_URI = "http://libtorrent.rakshasa.no/downloads/rtorrent-${PV}.tar.gz \
+ file://autoconf-cross-fix.patch;patch=1"
+
+inherit autotools
+
diff --git a/recipes/libtorrent/rtorrent_0.8.3.bb b/recipes/libtorrent/rtorrent_0.8.3.bb
new file mode 100644
index 0000000000..9ae0eed011
--- /dev/null
+++ b/recipes/libtorrent/rtorrent_0.8.3.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Console bittorrent client using libtorrent"
+HOMEPAGE = "http://libtorrent.rakshasa.no"
+SECTION = "libs/network"
+LICENSE = "GPL"
+DEPENDS = "libtorrent curl ncurses gnutls libgpg-error"
+
+SRC_URI = "http://libtorrent.rakshasa.no/downloads/rtorrent-${PV}.tar.gz \
+ file://autoconf-cross-fix.patch;patch=1"
+
+inherit autotools
+
diff --git a/recipes/libtorrent/rtorrent_0.8.4.bb b/recipes/libtorrent/rtorrent_0.8.4.bb
new file mode 100644
index 0000000000..3390511ef9
--- /dev/null
+++ b/recipes/libtorrent/rtorrent_0.8.4.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Console bittorrent client using libtorrent"
+HOMEPAGE = "http://libtorrent.rakshasa.no"
+SECTION = "libs/network"
+LICENSE = "GPL"
+DEPENDS = "libtorrent curl ncurses gnutls libgpg-error"
+
+SRC_URI = "http://libtorrent.rakshasa.no/downloads/rtorrent-${PV}.tar.gz \
+ file://autoconf-cross-fix.patch;patch=1"
+
+PR = "r0"
+
+inherit autotools
+