aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxml
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libxml')
-rw-r--r--recipes/libxml/libxml2-native.inc18
-rw-r--r--recipes/libxml/libxml2-native_2.7.2.bb2
2 files changed, 11 insertions, 9 deletions
diff --git a/recipes/libxml/libxml2-native.inc b/recipes/libxml/libxml2-native.inc
index b819f95fba..c8182de91a 100644
--- a/recipes/libxml/libxml2-native.inc
+++ b/recipes/libxml/libxml2-native.inc
@@ -7,14 +7,16 @@ S = "${WORKDIR}/libxml2-${PV}"
inherit distutils-base autotools native pkgconfig
-EXTRA_OECONF = "\
- --with-python=${PYTHON_DIR} \
- --without-debug \
- --without-legacy \
- --with-catalog \
- --without-docbook \
- --with-c14n \
-"
+do_configure_prepend () {
+ EXTRA_OECONF = "\
+ --with-python=${PYTHON_DIR} \
+ --without-debug \
+ --without-legacy \
+ --with-catalog \
+ --without-docbook \
+ --with-c14n \
+ "
+}
do_stage () {
oe_runmake install
diff --git a/recipes/libxml/libxml2-native_2.7.2.bb b/recipes/libxml/libxml2-native_2.7.2.bb
index bcbfb6637b..24261d66f2 100644
--- a/recipes/libxml/libxml2-native_2.7.2.bb
+++ b/recipes/libxml/libxml2-native_2.7.2.bb
@@ -1,2 +1,2 @@
require libxml2-native.inc
-PR = "r1"
+PR = "r2"