aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxml
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libxml')
-rw-r--r--recipes/libxml/libxml2-native.inc4
-rw-r--r--recipes/libxml/libxml2-native_2.7.3.bb2
-rw-r--r--recipes/libxml/libxml2.inc8
3 files changed, 5 insertions, 9 deletions
diff --git a/recipes/libxml/libxml2-native.inc b/recipes/libxml/libxml2-native.inc
index 3f67152ca1..82d36b9f48 100644
--- a/recipes/libxml/libxml2-native.inc
+++ b/recipes/libxml/libxml2-native.inc
@@ -22,6 +22,6 @@ do_configure (){
autotools_do_configure ${EXTRA_LIBXML2_OECONF}
}
-do_stage () {
- oe_runmake install
+do_install_append() {
+ :
}
diff --git a/recipes/libxml/libxml2-native_2.7.3.bb b/recipes/libxml/libxml2-native_2.7.3.bb
index 48e35986f6..bcbfb6637b 100644
--- a/recipes/libxml/libxml2-native_2.7.3.bb
+++ b/recipes/libxml/libxml2-native_2.7.3.bb
@@ -1,2 +1,2 @@
require libxml2-native.inc
-PR = "r0"
+PR = "r1"
diff --git a/recipes/libxml/libxml2.inc b/recipes/libxml/libxml2.inc
index 101489e8d2..b324228a2e 100644
--- a/recipes/libxml/libxml2.inc
+++ b/recipes/libxml/libxml2.inc
@@ -5,7 +5,7 @@ LICENSE = "MIT"
SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
-INC_PR = "r2"
+INC_PR = "r3"
inherit autotools pkgconfig binconfig
@@ -13,11 +13,7 @@ EXTRA_OECONF = "--without-python --without-debug --without-legacy --with-catalog
export LDFLAGS += "-ldl"
-do_stage() {
- autotools_stage_all
- install -d ${STAGING_DATADIR}/aclocal/
- install -d ${STAGING_BINDIR_CROSS}
-
+do_install_append() {
install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
#this is need it by php during its install
install -m 0755 xml2-config ${STAGING_BINDIR_CROSS}