aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux-libc-headers/linux-libc-headers_2.6.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux-libc-headers/linux-libc-headers_2.6.18.bb')
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.18.bb40
1 files changed, 6 insertions, 34 deletions
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.18.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.18.bb
index 60d621b1dc..60472165b7 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.18.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.18.bb
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r3"
+PR = "r4"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2 \
file://arm-syscall-define.patch;patch=1"
@@ -39,42 +39,14 @@ do_compile () {
do_install() {
set_arch
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=${ARCH}
-}
-
-do_install_append_arm() {
- cp include/asm-arm/procinfo.h ${D}${includedir}/asm
-}
-
-STAGE_TEMP="${WORKDIR}/temp-staging"
-
-do_stage () {
- set_arch
- rm -rf ${STAGE_TEMP}
- mkdir -p ${STAGE_TEMP}
- oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}${exec_prefix} ARCH=${ARCH}
- if [ "${ARCH}" == "arm" ]; then
- cp include/asm-arm/procinfo.h ${STAGE_TEMP}${includedir}/asm
- fi
- install -d ${STAGING_INCDIR}
- rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
- cp -pfLR ${STAGE_TEMP}${includedir}/linux ${STAGING_INCDIR}/
- cp -pfLR ${STAGE_TEMP}${includedir}/asm ${STAGING_INCDIR}/
- cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${STAGING_INCDIR}/
- # Add UTS_RELEASE to version.h. UTS_RELEASE was moved from version.h to
+ # Add UTS_RELEASE to version.h. UTS_RELEASE was moved from version.h to
# utsrelease.h in order to avoid recompiling a kernel every time a localversion
- # changed. Since the our headers are static and we're not compiling an
- # actual kernel, re-adding UTS_RELEASE does't hurt, and it allows uclibc to
+ # changed. Since the our headers are static and we're not compiling an
+ # actual kernel, re-adding UTS_RELEASE does't hurt, and it allows uclibc to
# compile with kernel headers that work with EABI on ARM
echo '#define UTS_RELEASE "2.6.18"' >> ${STAGING_INCDIR}/linux/version.h
}
-do_stage_append_nylon () {
- install -d ${STAGING_INCDIR}/asm/
- cp -vpPR include/asm-${ARCH}/* ${STAGING_INCDIR}/asm/
- install -d ${CROSS_DIR}/${TARGET_SYS}/include/asm/
- cp -vpPR include/asm-${ARCH}/* ${CROSS_DIR}/${TARGET_SYS}/include/asm/
- cp -vpPR include/linux/* ${STAGING_INCDIR}/linux/
- install -d ${CROSS_DIR}/${TARGET_SYS}/include/linux/
- cp -vpPR include/linux/* ${CROSS_DIR}/${TARGET_SYS}/include/linux/
+do_install_append_arm() {
+ cp include/asm-arm/procinfo.h ${D}${includedir}/asm
}
-