summaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-ixp4xx_2.6.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-ixp4xx_2.6.20.bb')
-rw-r--r--recipes/linux/linux-ixp4xx_2.6.20.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/linux/linux-ixp4xx_2.6.20.bb b/recipes/linux/linux-ixp4xx_2.6.20.bb
new file mode 100644
index 0000000000..f70992ea86
--- /dev/null
+++ b/recipes/linux/linux-ixp4xx_2.6.20.bb
@@ -0,0 +1,22 @@
+require linux.inc
+require linux-ixp4xx.inc
+
+KERNEL_RELEASE = "2.6.20"
+
+PV = "${KERNEL_RELEASE}+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${KERNEL_RELEASE}.tar.bz2 \
+ svn://svn.nslu2-linux.org/svnroot/kernel/trunk/patches;module=${KERNEL_RELEASE};proto=http \
+ file://defconfig-${KERNEL_RELEASE}"
+
+S = "${WORKDIR}/linux-${KERNEL_RELEASE}"
+
+do_prepatch() {
+ mv ${WORKDIR}/${KERNEL_RELEASE} ${S}/patches && cd ${S} && quilt push -av
+ mv patches patches.ixp4xx
+ mv .pc .pc.old
+ mv ${WORKDIR}/defconfig-${KERNEL_RELEASE} ${WORKDIR}/defconfig
+}
+
+addtask prepatch after do_unpack before do_patch