aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-jlime-jornada7xx_2.6.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-jlime-jornada7xx_2.6.17.bb')
-rw-r--r--recipes/linux/linux-jlime-jornada7xx_2.6.17.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/linux/linux-jlime-jornada7xx_2.6.17.bb b/recipes/linux/linux-jlime-jornada7xx_2.6.17.bb
new file mode 100644
index 0000000000..0d95972010
--- /dev/null
+++ b/recipes/linux/linux-jlime-jornada7xx_2.6.17.bb
@@ -0,0 +1,37 @@
+SECTION = "kernel"
+DESCRIPTION = "JLime Linux kernel for Arm based Jornada 7xx"
+LICENSE = "GPL"
+PR = "r0"
+
+COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = "jornada7xx"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.17.tar.gz \
+ file://defconf_jlime \
+ file://AsmArm-ArchSa1100-Jornada720.patch;patch=0 \
+ file://Cpu-Sa1110-Jornada720.patch;patch=0 \
+ file://Kconfig-Arch-Jornada720.patch;patch=0 \
+ file://Kconfig-Keyboard-Jornada720.patch;patch=0 \
+ file://Kconfig-Touchscreen-Jornada720.patch;patch=0 \
+ file://Kconfig-Video-Jornada720.patch;patch=0 \
+ file://Mach-Sa1100-Jornada720.patch;patch=0 \
+ file://Makefile-Keyboard-Jornada720.patch;patch=0 \
+ file://Makefile-Touchscreen-Jornada720.patch;patch=0 \
+ file://Makefile-Video-Jornada720.patch;patch=0 \
+ file://Newfile-Epson1356fb.patch;patch=0 \
+ file://Newfile-Jornada720_kbd.patch;patch=0 \
+ file://Newfile-Jornada720_ts.patch;patch=0"
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+#Lets let 3.4.x handle the compilation of this one
+KERNEL_CCSUFFIX = "-3.4.4"
+
+ARCH = "arm"
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconf_jlime ${S}/.config
+}