aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-mainstone_2.6.25.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-mainstone_2.6.25.bb')
-rw-r--r--recipes/linux/linux-mainstone_2.6.25.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/linux/linux-mainstone_2.6.25.bb b/recipes/linux/linux-mainstone_2.6.25.bb
new file mode 100644
index 0000000000..d9599ef76c
--- /dev/null
+++ b/recipes/linux/linux-mainstone_2.6.25.bb
@@ -0,0 +1,25 @@
+require linux.inc
+
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for the Mainstone (PXA270 ref design)"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/v2.6.25/patch-2.6.25-rc4.bz2;patch=1 \
+ file://mainstone-keypad.patch;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-2.6.24"
+
+COMPATIBLE_HOST = 'arm.*-linux'
+
+ARCH = "arm"
+
+CMDLINE_CONSOLE ?= "ttyS0,115200n8"
+#CMDLINE_ROOT = "root=/dev/slug rootfstype=ext2,jffs2 initrd=0x01000000,10M mem=32M@0x00000000"
+#CMDLINE_ROOT = "root=/dev/ram0 rw rootfstype=ext2,jffs2 initrd=0x01000000,10M init=/linuxrc mem=32M@0x00000000"
+CMDLINE_ROOT = "root=/dev/mtdblock2 rootfstype=jffs2 console=ttyS0,115200 mem=64M"
+CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_CONSOLE}"
+
+COMPATIBLE_MACHINE = "mainstone"