summaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-omap-psp_2.6.32.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-omap-psp_2.6.32.bb')
-rw-r--r--recipes/linux/linux-omap-psp_2.6.32.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/linux/linux-omap-psp_2.6.32.bb b/recipes/linux/linux-omap-psp_2.6.32.bb
new file mode 100644
index 0000000000..3cea6d3b3a
--- /dev/null
+++ b/recipes/linux/linux-omap-psp_2.6.32.bb
@@ -0,0 +1,26 @@
+require linux.inc
+
+DESCRIPTION = "Linux kernel for OMAP processors"
+KERNEL_IMAGETYPE = "uImage"
+
+COMPATIBLE_MACHINE = "omap3evm|am3517-evm"
+
+SRCREV = "c08d6b523f37d246440c6371e6fe26bc9f7b8674"
+
+# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
+PR_append = "+gitr${SRCREV}"
+
+SRC_URI = "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=git;branch=master \
+ file://defconfig"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ install -d ${D}/boot
+ install -m 0644 Documentation/arm/OMAP/DSS ${D}/boot/
+}
+
+PACKAGES =+ "omap-dss-doc"
+FILES_omap-dss-doc = "/boot/DSS"
+
+