aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-smdk2440_2.6.20+git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-smdk2440_2.6.20+git.bb')
-rw-r--r--recipes/linux/linux-smdk2440_2.6.20+git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/linux/linux-smdk2440_2.6.20+git.bb b/recipes/linux/linux-smdk2440_2.6.20+git.bb
new file mode 100644
index 0000000000..b86d970e50
--- /dev/null
+++ b/recipes/linux/linux-smdk2440_2.6.20+git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Linux Kernel for smdk2440 compatible machines"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r1"
+
+GGSRC = "http://www.xora.org.uk/oe/patches/"
+
+SRC_URI = "git://opensource.wolfsonmicro.com/linux-2.6-asoc-ggdev;protocol=git;tag=asoc-merge-0002 \
+ file://0001-Enable-cs8900A-network-device-for-smdk2440-board.patch;patch=1 \
+ file://defconfig-smdk2440"
+
+S = "${WORKDIR}/git"
+
+inherit kernel
+
+COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = "smdk2440"
+
+do_configure() {
+ install ${WORKDIR}/defconfig-smdk2440 ${S}/.config
+ #oe_runmake s3c2410_defconfig
+ oe_runmake oldconfig
+}
+
+KERNEL_RELEASE = "2.6.21"