aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-x86_2.6.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-x86_2.6.20.bb')
-rw-r--r--recipes/linux/linux-x86_2.6.20.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/linux/linux-x86_2.6.20.bb b/recipes/linux/linux-x86_2.6.20.bb
new file mode 100644
index 0000000000..3872c50cba
--- /dev/null
+++ b/recipes/linux/linux-x86_2.6.20.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Linux Kernel for x86 compatible machines"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r5"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 "
+
+SRC_URI_append_x86 = "file://i486-defconfig"
+SRC_URI_append_i586 = "file://i586-defconfig"
+SRC_URI_append_i686 = "file://i686-defconfig"
+
+S = "${WORKDIR}/linux-${PV}"
+
+KERNEL_IMAGETYPE ?= "bzImage"
+
+inherit kernel
+
+COMPATIBLE_HOST = "i.86.*-linux"
+
+do_configure_prepend_x86() {
+ install -m 0644 ${WORKDIR}/i486-defconfig ${S}/.config
+}
+
+do_configure_prepend_i586-generic() {
+ install -m 0644 ${WORKDIR}/i586-defconfig ${S}/.config
+}
+
+do_configure_prepend_i686() {
+ install -m 0644 ${WORKDIR}/i686-defconfig ${S}/.config
+}