aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/logicpd-pxa270_2.6.17-rc5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/logicpd-pxa270_2.6.17-rc5.bb')
-rw-r--r--recipes/linux/logicpd-pxa270_2.6.17-rc5.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/linux/logicpd-pxa270_2.6.17-rc5.bb b/recipes/linux/logicpd-pxa270_2.6.17-rc5.bb
new file mode 100644
index 0000000000..e7ab462c0b
--- /dev/null
+++ b/recipes/linux/logicpd-pxa270_2.6.17-rc5.bb
@@ -0,0 +1,29 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for the LogicPD Zoom(PXA270 ref design)"
+LICENSE = "GPL"
+PR = "r3"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/linux-2.6.17-rc5.tar.bz2 \
+ file://linux-2.6.17-rc5.patch;pnum=0;patch=1 \
+ file://ucb1400-ac97-audio.patch;pnum=1;patch=1 \
+ file://ucb1400-touchscreen.patch;pnum=1;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-2.6.17-rc5"
+
+COMPATIBLE_HOST = 'arm.*-linux'
+
+inherit kernel
+inherit package
+
+ARCH = "arm"
+
+FILES_kernel-image = ""
+
+do_configure_prepend() {
+# install -m 0644 ${S}/arch/arm/configs/lpd270_defconfig ${S}/.config
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+
+}
+
+COMPATIBLE_MACHINE = "logicpd-pxa270"