aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/litephone/litephone_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/litephone/litephone_git.bb')
-rw-r--r--recipes/litephone/litephone_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/litephone/litephone_git.bb b/recipes/litephone/litephone_git.bb
new file mode 100644
index 0000000000..e209a1c0ca
--- /dev/null
+++ b/recipes/litephone/litephone_git.bb
@@ -0,0 +1,26 @@
+require litephone.inc
+
+SRCREV = "4c9f16d9acc6cd18fc3f647b7e4f44a2d3bdd7b6"
+PV = "0.1+gitr${SRCREV}"
+PR = "${INC_PR}.0"
+
+SRC_URI = "git://git.senfdax.de/git/litephone;protocol=http \
+ file://files/litephone.desktop"
+
+S = "${WORKDIR}/git/"
+
+do_install() {
+ install -d ${D}/${datadir}/pixmaps
+ install -m 644 ${S}/pics/blue/Mobile.png ${D}/${datadir}/pixmaps/litephone-mobile.png
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/litephone ${D}/${bindir}
+ install -d ${D}/etc/litephone
+ install ${S}/style_sheet.conf ${D}/etc/litephone/
+ install -d ${D}/${datadir}/litephone/translations
+ install ${S}/translations/*.qm ${D}/${datadir}/litephone/translations/
+ install -d ${D}/${datadir}/applications
+ install ${WORKDIR}/files/litephone.desktop ${D}/${datadir}/applications/
+}
+
+FILES_${PN}-locale-pl-pl += "/usr/share/litephone/translations/litephone_pl.qm"
+PACKAGES =+ "${PN}-locale-pl-pl"