aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/literki/literki
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/literki/literki')
-rw-r--r--recipes/literki/literki/makefile.patch61
-rw-r--r--recipes/literki/literki/noswitcher.patch21
-rw-r--r--recipes/literki/literki/sliderheight.patch21
3 files changed, 103 insertions, 0 deletions
diff --git a/recipes/literki/literki/makefile.patch b/recipes/literki/literki/makefile.patch
new file mode 100644
index 0000000000..c6f78f0754
--- /dev/null
+++ b/recipes/literki/literki/makefile.patch
@@ -0,0 +1,61 @@
+commit d2ad0f4591619aa176edfb618971d0c8ff608a69
+Author: Yann Dirson <ydirson@altern.org>
+Date: Tue Aug 3 22:35:25 2010 +0200
+
+ Make the Makefile suitable for packaging and cross-compiling.
+
+ This includes normalisation of variable names to minimize packaging
+ work, as well as an install target.
+
+ Signed-off-by: Yann Dirson <ydirson@altern.org>
+
+diff --git a/Makefile b/Makefile
+index f300953..834e6f6 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,18 +1,39 @@
++DESTDIR=
++prefix=/usr
++bindir=$(prefix)/bin
++datadir=$(prefix)/share
++sysconfdir=/etc
++
+ PLIKI=display.o keymap.o keys.o keyboard.o applet.o launcher.o logger.o slider.o image_cache.o touchpad.o switcher.o vibrator.o
+
+ LIBS=-lX11 -lXext -lXtst -lpthread -lXrandr -lpng -lfakekey
+
+-CXXCOMPILE=g++
++CXX=g++
++
++MYCFLAGS = -g $(shell freetype-config --cflags)
++MYLDFLAGS = -g $(shell freetype-config --libs)
+
+-CFLAGS=-g `freetype-config --cflags`
+-LDFLAGS=-g `freetype-config --libs`
++all: literki
+
+ %.o: %.cpp
+- $(CXXCOMPILE) $(CFLAGS) -c $<
++ $(CXX) $(CXXFLAGS) $(MYCFLAGS) -c $<
+
+-all: $(PLIKI)
+- g++ $(LIBS) $(LDFLAGS) -o literki $(PLIKI)
++literki: $(PLIKI)
++ $(CXX) $(LDFLAGS) $(LIBS) $(MYLDFLAGS) -o $@ $^
+
+ clean:
+ rm *.o
+ rm literki
++
++install:
++ install -d -m755 \
++ $(DESTDIR)$(bindir) \
++ $(DESTDIR)$(sysconfdir)/literki \
++ $(DESTDIR)$(datadir)/applications \
++ $(DESTDIR)$(datadir)/pixmaps \
++ $(DESTDIR)$(datadir)/literki/png
++ install -m755 literki $(DESTDIR)$(bindir)/
++ install -m755 literki.conf *layout.conf $(DESTDIR)$(sysconfdir)/literki/
++ install -m644 png/* $(DESTDIR)$(datadir)/literki/png/
++ install -m644 literki.desktop $(DESTDIR)$(datadir)/applications/
++ install -m644 literki.png $(DESTDIR)$(datadir)/pixmaps/
diff --git a/recipes/literki/literki/noswitcher.patch b/recipes/literki/literki/noswitcher.patch
new file mode 100644
index 0000000000..2485d3fa2c
--- /dev/null
+++ b/recipes/literki/literki/noswitcher.patch
@@ -0,0 +1,21 @@
+commit 4134b39a3297f1a4316fc4ea9b21226450db0307
+Author: Yann Dirson <ydirson@altern.org>
+Date: Tue Aug 3 23:30:55 2010 +0200
+
+ Disable author's switcher in config file.
+
+ Signed-off-by: Yann Dirson <ydirson@altern.org>
+
+diff --git a/literki.conf b/literki.conf
+index 3322509..3c47bda 100644
+--- a/literki.conf
++++ b/literki.conf
+@@ -22,7 +22,7 @@ landscape_touchpad_width 440
+ landscape_touchpad_height 180
+
+
+-switcher_on yes
++switcher_on no
+ switcher_width 400
+ switcher_height 230
+
diff --git a/recipes/literki/literki/sliderheight.patch b/recipes/literki/literki/sliderheight.patch
new file mode 100644
index 0000000000..f41b863918
--- /dev/null
+++ b/recipes/literki/literki/sliderheight.patch
@@ -0,0 +1,21 @@
+commit 752db9abcce80fc2713e9892444894a86c7f59a0
+Author: Yann Dirson <ydirson@altern.org>
+Date: Tue Aug 3 23:30:11 2010 +0200
+
+ Make slider less high to allow unlocking screen in shr.
+
+ Signed-off-by: Yann Dirson <ydirson@altern.org>
+
+diff --git a/literki.conf b/literki.conf
+index 3c47bda..ae4219f 100644
+--- a/literki.conf
++++ b/literki.conf
+@@ -27,7 +27,7 @@ switcher_width 400
+ switcher_height 230
+
+ slider_width 240
+-slider_height 80
++slider_height 50
+ landscape_slider_width 240
+ landscape_slider_height 80
+ slider_dist 50