aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm/llvm-common.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/llvm/llvm-common.bb')
-rw-r--r--recipes/llvm/llvm-common.bb10
1 files changed, 4 insertions, 6 deletions
diff --git a/recipes/llvm/llvm-common.bb b/recipes/llvm/llvm-common.bb
index b7f2bfc011..9c1a4e538c 100644
--- a/recipes/llvm/llvm-common.bb
+++ b/recipes/llvm/llvm-common.bb
@@ -1,14 +1,12 @@
DESCRIPTION = "Helper script for OE's llvm support"
+BBCLASSEXTEND = "native"
+
SRC_URI = "file://llvm-config"
PACKAGES = ""
do_install() {
- :
-}
-
-do_stage() {
- install -d ${STAGING_BINDIR_CROSS}
- install -m 0755 ${WORKDIR}/llvm-config ${STAGING_BINDIR_CROSS}
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
}