aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm/llvm_2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/llvm/llvm_2.5.bb')
-rw-r--r--recipes/llvm/llvm_2.5.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/recipes/llvm/llvm_2.5.bb b/recipes/llvm/llvm_2.5.bb
index c0ce3345b8..d8a8d1893b 100644
--- a/recipes/llvm/llvm_2.5.bb
+++ b/recipes/llvm/llvm_2.5.bb
@@ -1,7 +1,3 @@
-# TODO:
-# - packages examples
-# - fix staging (and probably llvm-config script)
-
DESCRIPTION = "The Low Level Virtual Machine"
HOMEPAGE = "http://llvm.org"
LICENSE = "various"
@@ -11,6 +7,8 @@ SRC_URI = "\
file://fix-build.patch;patch=1 \
"
+PR = "r1"
+
DEPENDS = "llvm-native"
inherit cmake
@@ -30,7 +28,11 @@ EXTRA_OECMAKE = "\
"
do_stage() {
- oe_runmake DESTDIR="${STAGE_TEMP}" install
+ oe_runmake DESTDIR="${STAGING_DIR_HOST}" install
+
+ install -d ${STAGING_INCDIR}/llvm
+ find include/llvm -name "*.h" -maxdepth 1 -exec \
+ install {} ${STAGING_INCDIR}/llvm \;
install -d ${STAGING_BINDIR_CROSS}