aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/llvm')
-rw-r--r--recipes/llvm/llvm-common-native.bb12
-rw-r--r--recipes/llvm/llvm-common.bb10
2 files changed, 4 insertions, 18 deletions
diff --git a/recipes/llvm/llvm-common-native.bb b/recipes/llvm/llvm-common-native.bb
deleted file mode 100644
index c2b79bd6a5..0000000000
--- a/recipes/llvm/llvm-common-native.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-require llvm-common.bb
-
-inherit native
-
-do_install() {
- :
-}
-
-do_stage() {
- install -d ${STAGING_BINDIR}
- install -m 0755 ${WORKDIR}/llvm-config ${STAGING_BINDIR}
-}
diff --git a/recipes/llvm/llvm-common.bb b/recipes/llvm/llvm-common.bb
index b7f2bfc011..9c1a4e538c 100644
--- a/recipes/llvm/llvm-common.bb
+++ b/recipes/llvm/llvm-common.bb
@@ -1,14 +1,12 @@
DESCRIPTION = "Helper script for OE's llvm support"
+BBCLASSEXTEND = "native"
+
SRC_URI = "file://llvm-config"
PACKAGES = ""
do_install() {
- :
-}
-
-do_stage() {
- install -d ${STAGING_BINDIR_CROSS}
- install -m 0755 ${WORKDIR}/llvm-config ${STAGING_BINDIR_CROSS}
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
}