aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lrzsz/lrzsz_0.12.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/lrzsz/lrzsz_0.12.20.bb')
-rw-r--r--recipes/lrzsz/lrzsz_0.12.20.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/lrzsz/lrzsz_0.12.20.bb b/recipes/lrzsz/lrzsz_0.12.20.bb
new file mode 100644
index 0000000000..b44945e35f
--- /dev/null
+++ b/recipes/lrzsz/lrzsz_0.12.20.bb
@@ -0,0 +1,36 @@
+LICENSE = "GPL"
+SECTION = "console/network"
+PRIORITY = "standard"
+DESCRIPTION = "Tools for zmodem/xmodem/ymodem file transfer"
+DEPENDS = ""
+PR = "r4"
+
+SRC_URI = "http://www.ohse.de/uwe/releases/lrzsz-${PV}.tar.gz \
+ file://autotools.patch;patch=1 \
+ file://makefile.patch;patch=1 \
+ file://gettext.patch;patch=1"
+
+inherit autotools gettext
+
+do_install() {
+ install -d ${D}${bindir}/
+ install -m 0755 src/lrz src/lsz ${D}${bindir}/
+}
+
+pkg_postinst() {
+ for util in rz rx rb; do
+ update-alternatives --install ${bindir}/$util $util lrz 100
+ done
+ for util in sz sx sb; do
+ update-alternatives --install ${bindir}/$util $util lsz 100
+ done
+}
+
+pkg_postrm() {
+ for util in rz rx rb; do
+ update-alternatives --remove $util ${bindir}/lrz
+ done
+ for util in sz sx sb; do
+ update-alternatives --remove $util ${bindir}/lsz
+ done
+} \ No newline at end of file