aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ltp/ltp-20080229/cross-compile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ltp/ltp-20080229/cross-compile.patch')
-rw-r--r--recipes/ltp/ltp-20080229/cross-compile.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/recipes/ltp/ltp-20080229/cross-compile.patch b/recipes/ltp/ltp-20080229/cross-compile.patch
new file mode 100644
index 0000000000..456bf4f135
--- /dev/null
+++ b/recipes/ltp/ltp-20080229/cross-compile.patch
@@ -0,0 +1,57 @@
+Index: ltp-full-20080229/Makefile
+===================================================================
+--- ltp-full-20080229.orig/Makefile 2008-02-29 08:55:41.000000000 +0100
++++ ltp-full-20080229/Makefile 2008-03-01 01:14:35.000000000 +0100
+@@ -33,11 +33,12 @@
+ endif
+ ifdef CROSS_COMPILER
+ CC=$(CROSS_COMPILER)gcc
++CPP=$(CROSS_COMPILER)g++
+ AR=$(CROSS_COMPILER)ar
+ endif
+
+ export CFLAGS += -Wall $(CROSS_CFLAGS)
+-export CC AR LDFLAGS
++export CC AR LDFLAGS CPP
+
+ -include config.mk
+
+Index: ltp-full-20080229/testcases/ballista/ballista/Makefile
+===================================================================
+--- ltp-full-20080229.orig/testcases/ballista/ballista/Makefile 2008-02-29 08:55:46.000000000 +0100
++++ ltp-full-20080229/testcases/ballista/ballista/Makefile 2008-03-01 01:14:35.000000000 +0100
+@@ -24,7 +24,7 @@
+ ########################
+
+ # compiler info for the host
+-CC = g++ -Wno-deprecated
++CC = $(CPP) -Wno-deprecated
+ CFLAGS = -w -O ${TARGET_DEF}
+ CLIBS = -lpthread -ldl -lnsl -rdynamic
+ TEST_MAN_FILE = selfHost
+Index: ltp-full-20080229/testcases/kernel/security/filecaps/Makefile
+===================================================================
+--- ltp-full-20080229.orig/testcases/kernel/security/filecaps/Makefile 2008-03-01 01:14:49.000000000 +0100
++++ ltp-full-20080229/testcases/kernel/security/filecaps/Makefile 2008-03-01 01:15:05.000000000 +0100
+@@ -20,7 +20,6 @@
+
+ SCRIPTS = filecapstest.sh checkforlibcap.sh checkforfilecaps.sh
+ ifeq ($(shell sh checkforlibcap.sh yesno),yes)
+-CC=gcc
+
+ CFLAGS += -I../../../../include -Wall
+ LDLIBS += -L../../../../lib -lltp -lcap
+@@ -29,11 +28,11 @@
+ TARGETS = $(patsubst %.c,%,$(SRCS))
+ INSTALLTARGETS = $(TARGETS) $(SCRIPTS)
+ all: $(TARGETS)
+- gcc -o checkforlibcap gotlibcap.c
++ $(CC) -o checkforlibcap gotlibcap.c
+ else
+ all:
+ @echo "setcap or xattr headers not installed. Please install libcap from"; echo "ftp://ftp.kernel.org/pub/linux/libs/security/linux-privs/libcap2"; echo "Then make clean in ltp or ltp/testcases/kernel/security/filecaps, and recompile ltp."
+- gcc -o checkforlibcap nolibcap.c
++ $(CC) -o checkforlibcap nolibcap.c
+ TARGETS =
+ endif
+