aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lua/lua-native_5.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/lua/lua-native_5.0.2.bb')
-rw-r--r--recipes/lua/lua-native_5.0.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/lua/lua-native_5.0.2.bb b/recipes/lua/lua-native_5.0.2.bb
new file mode 100644
index 0000000000..bf70f84ac0
--- /dev/null
+++ b/recipes/lua/lua-native_5.0.2.bb
@@ -0,0 +1,15 @@
+require lua.inc
+
+PR = "r2"
+DEPENDS += "readline-native"
+SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz \
+ file://debian.patch;patch=1 \
+ file://make.patch;patch=1 \
+ file://advanced-readline.patch;patch=1"
+# http://lua-users.org/files/wiki_insecure/power_patches/5.0/advanced-readline.patch;patch=1"
+S = "${WORKDIR}/lua-${PV}"
+FILESPATH = "${FILE_DIRNAME}/lua-${PV}:${FILE_DIRNAME}/lua:${FILE_DIRNAME}/files"
+
+inherit native
+require lua-build.inc
+