aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/madwifi/madwifi-ng_r3314-20080131.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/madwifi/madwifi-ng_r3314-20080131.bb')
-rw-r--r--recipes/madwifi/madwifi-ng_r3314-20080131.bb31
1 files changed, 26 insertions, 5 deletions
diff --git a/recipes/madwifi/madwifi-ng_r3314-20080131.bb b/recipes/madwifi/madwifi-ng_r3314-20080131.bb
index 38f63f3dfe..6a2c2a6149 100644
--- a/recipes/madwifi/madwifi-ng_r3314-20080131.bb
+++ b/recipes/madwifi/madwifi-ng_r3314-20080131.bb
@@ -2,12 +2,33 @@
require madwifi-ng_r.inc
-SRC_URI += " \
- file://30-define-ioreadwrite32be-for-little-endian-too.patch \
- "
-
# PR set after the include, to override what's set in the included file.
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
+
+# versions of OpenWrt backfire (10.03)
+HAL_VERSION = "20090508"
+SRCREV = "20550"
+SRC_URI += " \
+ svn://svn.openwrt.org/openwrt/trunk/package/madwifi;module=patches \
+ http://mirror2.openwrt.org/sources/ath_hal-${HAL_VERSION}.tgz;name=hal \
+ file://fix-target-mips32.patch \
+ file://remove-wprobe.patch;apply=no \
+ "
SRC_URI[md5sum] = "2c7352cbbdac995de8c3bce5b80db5f2"
SRC_URI[sha256sum] = "0599c75b95ba63bdc554cb8124192e62c75fbeb71b9e8a5a7bc351c8e0666758"
+SRC_URI[hal.md5sum] = "4ab7ae8bdb96c0be388c98bf8f92d5ca"
+SRC_URI[hal.sha256sum] = "ced93d25aea7ee43807147a0269e69a072e718d59e7dab904bbe48b900409483"
+
+addtask postpatch after do_patch before do_configure
+
+do_postpatch() {
+ rm -rf hal
+ cp -a ${WORKDIR}/ath_hal-${HAL_VERSION} hal
+ rm -f ${WORKDIR}/patches/446-single_module.patch
+ for i in ${WORKDIR}/patches/*.patch; do
+ oenote "Applying openwrt patch '$i'"
+ patch -p1 -i $i
+ done
+ patch -p1 -i ${WORKDIR}/remove-wprobe.patch
+}