aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/maemo-mapper/maemo-mapper_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/maemo-mapper/maemo-mapper_svn.bb')
-rw-r--r--recipes/maemo-mapper/maemo-mapper_svn.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/maemo-mapper/maemo-mapper_svn.bb b/recipes/maemo-mapper/maemo-mapper_svn.bb
new file mode 100644
index 0000000000..39e89fcc98
--- /dev/null
+++ b/recipes/maemo-mapper/maemo-mapper_svn.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "GPS navigation/map display software"
+LICENSE = "GPL"
+DEPENDS = "gdbm libconic sqlite3 gtk+ libhildonfm libosso osso-ic-oss libosso-help gnome-vfs dbus bluez-libs"
+RDEPENDS = "bluez-utils"
+RRECOMMENDS = "gpsd flite"
+PV = "2.0.3+svnr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "svn://garage.maemo.org/svn/maemo-mapper;proto=https;module=trunk \
+ file://mapper-hildon1.diff;patch=1;maxrev=108"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools pkgconfig
+
+do_install_append () {
+ install -d ${D}${datadir}/applications/
+ mv ${D}/maemo-mapper.desktop ${D}${datadir}/applications/
+}
+
+#FILES_${PN} += "${datadir}/icons"