aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/maemo/libosso-help_1.0.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/maemo/libosso-help_1.0.01.bb')
-rw-r--r--recipes/maemo/libosso-help_1.0.01.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/maemo/libosso-help_1.0.01.bb b/recipes/maemo/libosso-help_1.0.01.bb
new file mode 100644
index 0000000000..867cc66b7d
--- /dev/null
+++ b/recipes/maemo/libosso-help_1.0.01.bb
@@ -0,0 +1,21 @@
+LICENSE = "LGPL"
+PR = "r0"
+
+DEPENDS = "libosso hildon-lgpl hildon-base-lib hildon-libs"
+SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/libo/${PN}/libosso-help_${PV}.tar.gz \
+ file://no-Werror.patch;patch=1;pnum=0 \
+ file://help-header-pp.patch;patch=1;pnum=0"
+
+inherit pkgconfig autotools
+
+S = "${WORKDIR}/libosso-help-sdk-${PV}"
+
+#FILES_${PN} += "${libdir}/dbus-1.0/services/ ${libdir}/outo/*.so ${libdir}/outo/*bin ${libdir}/outo/mimedummy.doc"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}
+ install -m 644 helplib/*.h ${STAGING_INCDIR}
+ install -m644 helplib/.libs/libossohelp.so ${STAGING_LIBDIR}
+ install -m644 helplib/.libs/libossohelp.so.0 ${STAGING_LIBDIR}
+ install -m644 helplib/.libs/libossohelp.so.0.0.0 ${STAGING_LIBDIR}
+}