aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/make
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/make')
-rw-r--r--recipes/make/files/SCCS.patch16
-rw-r--r--recipes/make/make-native_3.80.bb14
-rw-r--r--recipes/make/make-native_3.81.bb14
-rw-r--r--recipes/make/make.inc19
-rw-r--r--recipes/make/make_3.80.bb3
-rw-r--r--recipes/make/make_3.81.bb3
-rw-r--r--recipes/make/mingw-make-canadian-sdk_3.81.bb16
7 files changed, 85 insertions, 0 deletions
diff --git a/recipes/make/files/SCCS.patch b/recipes/make/files/SCCS.patch
new file mode 100644
index 0000000000..c998e118ed
--- /dev/null
+++ b/recipes/make/files/SCCS.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- make-3.80/configure.in~SCCS
++++ make-3.80/configure.in
+@@ -264,7 +264,7 @@
+ [Define this if the SCCS 'get' command understands the '-G<file>' option.]);;
+ esac
+ fi
+-rm -f s.conftest conftoast
++rm -f s.conftest conftoast SCCS/*s.conftest
+
+ # Check the system to see if it provides GNU glob. If not, use our
+ # local version.
diff --git a/recipes/make/make-native_3.80.bb b/recipes/make/make-native_3.80.bb
new file mode 100644
index 0000000000..509558c405
--- /dev/null
+++ b/recipes/make/make-native_3.80.bb
@@ -0,0 +1,14 @@
+PR = "r0"
+
+S = "${WORKDIR}/make-${PV}"
+
+inherit native
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 make ${STAGING_BINDIR}
+}
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/make-${PV}"
+
+require make_${PV}.bb
diff --git a/recipes/make/make-native_3.81.bb b/recipes/make/make-native_3.81.bb
new file mode 100644
index 0000000000..509558c405
--- /dev/null
+++ b/recipes/make/make-native_3.81.bb
@@ -0,0 +1,14 @@
+PR = "r0"
+
+S = "${WORKDIR}/make-${PV}"
+
+inherit native
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 make ${STAGING_BINDIR}
+}
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/make-${PV}"
+
+require make_${PV}.bb
diff --git a/recipes/make/make.inc b/recipes/make/make.inc
new file mode 100644
index 0000000000..8a43f40a24
--- /dev/null
+++ b/recipes/make/make.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "GNU Make examines the timestamps on a set of \
+interdependent files, and, if necessary, issues commands \
+to bring them up-to-date."
+HOMEPAGE = "http://www.gnu.org/software/make/"
+SECTION = "devel"
+LICENSE = "GPL"
+
+SRC_URI = "${GNU_MIRROR}/make/make-${PV}.tar.bz2 \
+ file://SCCS.patch;patch=1"
+
+inherit autotools
+
+do_configure_prepend() {
+ if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibcgnueabi" ]; then
+ export make_cv_sys_gnu_glob="no"
+ export GLOBINC=-I`pwd`/glob
+ export GLOBLIB=glob/libglob.a
+ fi
+}
diff --git a/recipes/make/make_3.80.bb b/recipes/make/make_3.80.bb
new file mode 100644
index 0000000000..797d26b3be
--- /dev/null
+++ b/recipes/make/make_3.80.bb
@@ -0,0 +1,3 @@
+PR = "r0"
+
+require make.inc
diff --git a/recipes/make/make_3.81.bb b/recipes/make/make_3.81.bb
new file mode 100644
index 0000000000..797d26b3be
--- /dev/null
+++ b/recipes/make/make_3.81.bb
@@ -0,0 +1,3 @@
+PR = "r0"
+
+require make.inc
diff --git a/recipes/make/mingw-make-canadian-sdk_3.81.bb b/recipes/make/mingw-make-canadian-sdk_3.81.bb
new file mode 100644
index 0000000000..3479dad249
--- /dev/null
+++ b/recipes/make/mingw-make-canadian-sdk_3.81.bb
@@ -0,0 +1,16 @@
+PR = "r0"
+
+require make.inc
+
+inherit canadian-sdk
+
+DESCRIPTION = "GNU Make examines the timestamps on a set of \
+interdependent files, and, if necessary, issues commands \
+to bring them up-to-date - MinGW port."
+HOMEPAGE = "http://www.mingw.org/"
+
+DEPENDS = "virtual/${HOST_PREFIX}binutils virtual/${HOST_PREFIX}gcc"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/mingw/mingw32-make-3.81-20080326-src.tar.gz"
+
+S = "${WORKDIR}/make-${PV}-patched"