aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mamona/gcc-noemu_4.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mamona/gcc-noemu_4.1.1.bb')
-rw-r--r--recipes/mamona/gcc-noemu_4.1.1.bb54
1 files changed, 27 insertions, 27 deletions
diff --git a/recipes/mamona/gcc-noemu_4.1.1.bb b/recipes/mamona/gcc-noemu_4.1.1.bb
index 32e021bb98..9410f28f97 100644
--- a/recipes/mamona/gcc-noemu_4.1.1.bb
+++ b/recipes/mamona/gcc-noemu_4.1.1.bb
@@ -12,38 +12,38 @@ inherit autotools gettext
require gcc-package-noemu.inc
SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
- file://100-uclibc-conf.patch;patch=1 \
- file://110-arm-eabi.patch;patch=1 \
- file://200-uclibc-locale.patch;patch=1 \
- file://300-libstdc++-pic.patch;patch=1 \
- file://301-missing-execinfo_h.patch;patch=1 \
- file://302-c99-snprintf.patch;patch=1 \
- file://303-c99-complex-ugly-hack.patch;patch=1 \
- file://304-index_macro.patch;patch=1 \
- file://602-sdk-libstdc++-includes.patch;patch=1 \
- file://740-sh-pr24836.patch;patch=1 \
- file://800-arm-bigendian.patch;patch=1 \
- file://801-arm-bigendian-eabi.patch;patch=1 \
- file://arm-nolibfloat.patch;patch=1 \
- file://arm-softfloat.patch;patch=1 \
- file://gcc41-configure.in.patch;patch=1 \
- file://arm-thumb.patch;patch=1 \
- file://arm-thumb-cache.patch;patch=1 \
- file://ldflags.patch;patch=1 \
- file://cse.patch;patch=1 \
- file://zecke-xgcc-cpp.patch;patch=1 \
- file://unbreak-armv4t.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
- file://gcc-4.1.1-pr13685-1.patch;patch=1 \
- file://gcc-ignore-cache.patch;patch=1 \
+ file://100-uclibc-conf.patch;apply=yes \
+ file://110-arm-eabi.patch;apply=yes \
+ file://200-uclibc-locale.patch;apply=yes \
+ file://300-libstdc++-pic.patch;apply=yes \
+ file://301-missing-execinfo_h.patch;apply=yes \
+ file://302-c99-snprintf.patch;apply=yes \
+ file://303-c99-complex-ugly-hack.patch;apply=yes \
+ file://304-index_macro.patch;apply=yes \
+ file://602-sdk-libstdc++-includes.patch;apply=yes \
+ file://740-sh-pr24836.patch;apply=yes \
+ file://800-arm-bigendian.patch;apply=yes \
+ file://801-arm-bigendian-eabi.patch;apply=yes \
+ file://arm-nolibfloat.patch;apply=yes \
+ file://arm-softfloat.patch;apply=yes \
+ file://gcc41-configure.in.patch;apply=yes \
+ file://arm-thumb.patch;apply=yes \
+ file://arm-thumb-cache.patch;apply=yes \
+ file://ldflags.patch;apply=yes \
+ file://cse.patch;apply=yes \
+ file://zecke-xgcc-cpp.patch;apply=yes \
+ file://unbreak-armv4t.patch;apply=yes \
+ file://fix-ICE-in-arm_unwind_emit_set.diff;apply=yes \
+ file://gcc-4.1.1-pr13685-1.patch;apply=yes \
+ file://gcc-ignore-cache.patch;apply=yes \
"
-SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
+SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;apply=yes "
#This is a dirty hack to get gcc 4.1.1 to compile for glibc AND uclibc on ppc
#the patch that is need it to get gcc support soft-floats with glibc, makes gcc fail with uclibc
-SRC_URI_append_linux = " file://ppc-gcc-41-20060515.patch;patch=1 \
- file://ppc-sfp-long-double-gcc411-7.patch;patch=1 "
+SRC_URI_append_linux = " file://ppc-gcc-41-20060515.patch;apply=yes \
+ file://ppc-sfp-long-double-gcc411-7.patch;apply=yes "
#Set the fortran bits