aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/masqmail
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/masqmail')
-rw-r--r--recipes/masqmail/masqmail_0.2.21.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/masqmail/masqmail_0.2.21.bb b/recipes/masqmail/masqmail_0.2.21.bb
new file mode 100644
index 0000000000..05f377e4e5
--- /dev/null
+++ b/recipes/masqmail/masqmail_0.2.21.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "MasqMail is a mail server designed for hosts that do not have \
+a permanent internet connection eg. a home network or a single host at home. \
+It has special support for connections to different ISPs. It replaces sendmail \
+or other MTAs such as qmail or exim."
+HOMEPAGE = "http://innominate.org/kurth/masqmail/"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/m/${PN}/${PN}_${PV}.orig.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--disable-glibtest"
+EXTRA_OECONF += "--disable-resolver"
+
+# These are the standard Debian values for ownership of the programs,
+# this stuff fakes out the install script chown operations then replicates
+# them by setting the ipkg owner/group to the desired values - everything
+# ends up owned by the nominated user.
+MAIL_USER ?= "mail"
+MAIL_GROUP ?= "mail"
+
+EXTRA_OECONF += "--with-user=$(id -u)"
+EXTRA_OECONF += "--with-group=$(id -g)"
+
+IPKGBUILDCMD = "ipkg-build -o ${MAIL_USER} -g ${MAIL_GROUP}"