aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/matchbox-applet-tasks
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/matchbox-applet-tasks')
-rw-r--r--recipes/matchbox-applet-tasks/mb-applet-tasks_1.0.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/matchbox-applet-tasks/mb-applet-tasks_1.0.0.bb b/recipes/matchbox-applet-tasks/mb-applet-tasks_1.0.0.bb
new file mode 100644
index 0000000000..6193067bfa
--- /dev/null
+++ b/recipes/matchbox-applet-tasks/mb-applet-tasks_1.0.0.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Tasks applet switcher for matchbox"
+LICENSE = "GPLv2"
+DEPENDS = "gtk+ libwnck libmatchbox"
+
+PR = "r1"
+
+CFLAGS += "-I${STAGING_INCDIR} \
+ -I${STAGING_INCDIR}/gtk-2.0 \
+ -I${STAGING_INCDIR}/glib-2.0 \
+ -I${STAGING_INCDIR}/freetype2 \
+ -I${STAGING_INCDIR}/atk-1.0 \
+ -I${STAGING_INCDIR}/libwnck-1.0 \
+ -I${STAGING_LIBDIR}/gtk-2.0/include \
+ -I${STAGING_INCDIR}/cairo \
+ -DWNCK_I_KNOW_THIS_IS_UNSTABLE"
+
+SRC_URI = "http://www.pdaxrom.org/download/1.1.0beta4/src/${P}.tar.bz2"
+
+do_install() {
+install -d ${D}/${datadir}/applications
+install -d ${D}/${bindir}
+
+install -m 755 mb-applet-tasks ${D}/${bindir}
+install -m 644 mb-applet-tasks.desktop ${D}/${datadir}/applications
+}
+
+
+
+
+
+