aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mathomatic
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mathomatic')
-rw-r--r--recipes/mathomatic/mathomatic.inc19
-rw-r--r--recipes/mathomatic/mathomatic_12.4.2.bb3
-rw-r--r--recipes/mathomatic/mathomatic_unstable.bb7
3 files changed, 29 insertions, 0 deletions
diff --git a/recipes/mathomatic/mathomatic.inc b/recipes/mathomatic/mathomatic.inc
new file mode 100644
index 0000000000..64fe0fe60d
--- /dev/null
+++ b/recipes/mathomatic/mathomatic.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "A small, portable, general purpose CAS (Computer Algebra System)."
+HOMEPAGE = "http://mathomatic.orgserve.de/math/"
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "readline"
+
+inherit autotools
+
+EXTRA_OEMAKE = "READLINE=1"
+
+do_install () {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ docdir="${D}${docdir}/${PN}" \
+ install
+}
diff --git a/recipes/mathomatic/mathomatic_12.4.2.bb b/recipes/mathomatic/mathomatic_12.4.2.bb
new file mode 100644
index 0000000000..33e63feda9
--- /dev/null
+++ b/recipes/mathomatic/mathomatic_12.4.2.bb
@@ -0,0 +1,3 @@
+require mathomatic.inc
+
+SRC_URI = "http://www.panix.com/~gesslein/mathomatic-${PV}.tgz"
diff --git a/recipes/mathomatic/mathomatic_unstable.bb b/recipes/mathomatic/mathomatic_unstable.bb
new file mode 100644
index 0000000000..e717866b4e
--- /dev/null
+++ b/recipes/mathomatic/mathomatic_unstable.bb
@@ -0,0 +1,7 @@
+require mathomatic.inc
+
+SRC_URI = "http://www.panix.com/~gesslein/am.tgz"
+S = "${WORKDIR}/mathomatic-12.4.2"
+
+# source snapshot changes every day
+BROKEN = "1"