aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/memtester/memtester_4.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/memtester/memtester_4.0.6.bb')
-rw-r--r--recipes/memtester/memtester_4.0.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/memtester/memtester_4.0.6.bb b/recipes/memtester/memtester_4.0.6.bb
new file mode 100644
index 0000000000..1fb4541eb6
--- /dev/null
+++ b/recipes/memtester/memtester_4.0.6.bb
@@ -0,0 +1,22 @@
+SECTION = "console/utils"
+DESCRIPTION = "Utility to test for faulty memory subsystem"
+LICENSE = "GPLv2"
+PR = "r0"
+
+SRC_URI = "http://pyropus.ca/software/memtester/old-versions/memtester-${PV}.tar.gz"
+SRC_URI += "file://Makefile.patch;patch=1"
+
+S = "${WORKDIR}/memtester-${PV}"
+
+do_compile () {
+ echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
+ echo '${CC} ${LDFLAGS}' > conf-ld
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man8
+ install -m 0755 memtester ${D}${bindir}/
+ install -m 0755 memtester.8 ${D}${mandir}/man8/
+}