aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mgetty/mgetty-1.1.30/03-callback_Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mgetty/mgetty-1.1.30/03-callback_Makefile')
-rw-r--r--recipes/mgetty/mgetty-1.1.30/03-callback_Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/mgetty/mgetty-1.1.30/03-callback_Makefile b/recipes/mgetty/mgetty-1.1.30/03-callback_Makefile
new file mode 100644
index 0000000000..4ef5e088f2
--- /dev/null
+++ b/recipes/mgetty/mgetty-1.1.30/03-callback_Makefile
@@ -0,0 +1,20 @@
+--- mgetty-1.1.27.orig/callback/Makefile
++++ mgetty-1.1.27/callback/Makefile
+@@ -5,7 +5,7 @@
+ #
+
+ CC=gcc
+-CFLAGS=-O2 -I.. -g
++CFLAGS=-O2 -I..
+
+ zigzag:
+ cd .. ; $(MAKE) call-back
+@@ -40,7 +40,7 @@
+ # install programs
+ #
+ install: all
+- $(INSTALL) -s -m 700 -o root callback $(SBINDIR)
++ $(INSTALL) -s -m 755 -o root callback $(SBINDIR)
+ $(INSTALL) -s -m 4711 -o root ct $(BINDIR)
+
+ # source modules