aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/micro-evtd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/micro-evtd')
-rw-r--r--recipes/micro-evtd/micro-evtd_3.3.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/micro-evtd/micro-evtd_3.3.0.bb b/recipes/micro-evtd/micro-evtd_3.3.0.bb
new file mode 100644
index 0000000000..70a44be47d
--- /dev/null
+++ b/recipes/micro-evtd/micro-evtd_3.3.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "micro_evtd daemon for ARM Linkstations and Kurobox Pro"
+HOMEPAGE = "http://buffalo.nas-central.org/download/Users/lb_worm/micro_evtd/"
+SECTION = "console/network"
+PR = "r1"
+LICENSE = "GPL"
+COMPATIBLE_MACHINE = "(kuropro|lspro)"
+
+SRC_URI = "http://downloads.buffalo.nas-central.org/Users/timtimred/kuropro/micro-evtd-3.3.0.tar.gz"
+
+inherit update-rc.d
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o ${S}/micro_evtd ${S}/micro_evtd.c
+}
+
+do_install() {
+ install -D -m 0755 ${S}/micro_evtd ${D}${sbindir}/micro_evtd
+ install -D -m 0644 ${S}/microevtd ${D}${sysconfdir}/default/micro_evtd
+ install -D -m 0755 ${S}/EventScript ${D}${sysconfdir}/micro_evtd/EventScript
+ install -D -m 0755 ${S}/init ${D}${sysconfdir}/init.d/micro-evtd
+}
+
+INITSCRIPT_NAME = "micro-evtd"
+INITSCRIPT_PARAMS = "defaults"